summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-libs/postgresql-libs-8.2.6.ebuild')
-rw-r--r--dev-db/postgresql-libs/postgresql-libs-8.2.6.ebuild124
1 files changed, 0 insertions, 124 deletions
diff --git a/dev-db/postgresql-libs/postgresql-libs-8.2.6.ebuild b/dev-db/postgresql-libs/postgresql-libs-8.2.6.ebuild
deleted file mode 100644
index 5a53800..0000000
--- a/dev-db/postgresql-libs/postgresql-libs-8.2.6.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="none"
-inherit eutils toolchain-funcs versionator autotools
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-
-DESCRIPTION="PostgreSQL libraries"
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-SLOT="$(get_version_component_range 1-2)"
-# find . -name \*.po | xargs -n 1 basename | cut -d. -f1|sort|uniq|sed 's/^/linguas_/'
-IUSE_LINGUAS="
- linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
- linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
- linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
- linguas_tr linguas_zh_CN linguas_zh_TW"
-IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ldap ${IUSE_LINGUAS}"
-RESTRICT="test"
-
-wanted_languages() {
- for u in ${IUSE_LINGUAS} ; do
- use $u && echo ${u#linguas_}
- done
-}
-
-RDEPEND="kerberos? ( virtual/krb5 )
- pam? ( virtual/pam )
- readline? ( >=sys-libs/readline-4.1 )
- ssl? ( >=dev-libs/openssl-0.9.6-r1 )
- zlib? ( >=sys-libs/zlib-1.1.3 )
- >=app-admin/eselect-postgresql-0.2
- ldap? ( net-nds/openldap )
- "
-DEPEND="${RDEPEND}
- >=sys-devel/bison-1.875
- nls? ( sys-devel/gettext )"
-PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
-
-S="${WORKDIR}/postgresql-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/postgresql-${SLOT}-common.patch"
- epatch "${FILESDIR}/postgresql-${SLOT}-libs.patch"
-
- # to avoid collision - it only should be installed by server
- rm "${S}/src/backend/nls.mk"
-
- eautoconf
-}
-
-src_compile() {
- # TODO: test if PPC really cannot work with other CFLAGS settings
- # use ppc && CFLAGS="-pipe -fsigned-char"
- econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
- --datadir=/usr/share/postgresql-${SLOT} \
- --sysconfdir=/etc/postgresql-${SLOT} \
- --includedir=/usr/include/postgresql-${SLOT} \
- --with-locale-dir=/usr/share/postgresql-${SLOT}/locale \
- --mandir=/usr/share/postgresql-${SLOT}/man \
- --with-docdir=/usr/share/doc/${PF} \
- --enable-depend \
- --without-tcl \
- --without-perl \
- --without-python \
- $(use_with kerberos krb5) \
- "$(use_enable nls nls "$(wanted_languages)")" \
- $(use_with pam) \
- $(use_enable pg-intdatetime integer-datetimes ) \
- $(use_with readline) \
- $(use_with ssl openssl) \
- $(use_enable threads thread-safety ) \
- $(use_with zlib) \
- $(use_with ldap) \
- || die "configure failed"
-
- emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- insinto /usr/include/postgresql-${SLOT}/postmaster
- doins "${S}"/src/include/postmaster/*.h
- dodir /usr/share/postgresql-${SLOT}/man/man1
- tar -zxf "${S}"/doc/man.tar.gz -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
-
- dodoc README HISTORY doc/{README.*,TODO,bug.template}
-
- dodir /usr/lib/eselect-postgresql/slots/${SLOT}
- {
- echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\""
- echo "postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}"
- echo "postgres_datadir=/usr/share/postgresql-${SLOT}"
- echo "postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin"
- echo "postgres_symlinks=("
- IDIR="/usr/include/postgresql-${SLOT}"
- echo " " ${IDIR} /usr/include/postgresql
- echo " " {${IDIR},/usr/include}/libpq-fe.h
- echo " " {${IDIR},/usr/include}/libpq
- echo " " {${IDIR},/usr/include}/postgres_ext.h
- echo ")"
- } >"${D}/usr/lib/eselect-postgresql/slots/${SLOT}/libs"
- cat >"${T}"/50postgresql-95-${SLOT} <<-__EOF__
- LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
- MANPATH=/usr/share/postgresql-${SLOT}/man
- __EOF__
- doenvd "${T}/50postgresql-95-${SLOT}"
-}
-
-pkg_postinst() {
- eselect postgresql update
- [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
- elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql-${SLOT}/'."
-}
-
-pkg_postrm() {
- eselect postgresql update
-}