summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-server/files/postgresql-8.2-server.patch')
-rw-r--r--dev-db/postgresql-server/files/postgresql-8.2-server.patch103
1 files changed, 58 insertions, 45 deletions
diff --git a/dev-db/postgresql-server/files/postgresql-8.2-server.patch b/dev-db/postgresql-server/files/postgresql-8.2-server.patch
index 92e9d36..9e23f6a 100644
--- a/dev-db/postgresql-server/files/postgresql-8.2-server.patch
+++ b/dev-db/postgresql-server/files/postgresql-8.2-server.patch
@@ -1,8 +1,8 @@
-diff --git a/GNUmakefile.in b/GNUmakefile.in
-index 16f9057..0f6cee7 100644
---- a/GNUmakefile.in
-+++ b/GNUmakefile.in
-@@ -11,19 +11,16 @@ include $(top_builddir)/src/Makefile.global
+=== GNUmakefile.in
+==================================================================
+--- GNUmakefile.in (revision 14)
++++ GNUmakefile.in (local)
+@@ -11,19 +11,16 @@
all:
$(MAKE) -C doc all
$(MAKE) -C src all
@@ -22,11 +22,11 @@ index 16f9057..0f6cee7 100644
distprep:
$(MAKE) -C doc $@
-diff --git a/contrib/Makefile b/contrib/Makefile
-index 1787a1b..6b4104d 100644
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -18,19 +18,16 @@ WANTED_DIRS = \
+=== contrib/Makefile
+==================================================================
+--- contrib/Makefile (revision 14)
++++ contrib/Makefile (local)
+@@ -18,19 +18,16 @@
isn \
lo \
ltree \
@@ -47,10 +47,10 @@ index 1787a1b..6b4104d 100644
ifeq ($(with_openssl),yes)
WANTED_DIRS += sslinfo
-diff --git a/contrib/adminpack/Makefile b/contrib/adminpack/Makefile
-index ba864c1..1e2e96e 100644
---- a/contrib/adminpack/Makefile
-+++ b/contrib/adminpack/Makefile
+=== contrib/adminpack/Makefile
+==================================================================
+--- contrib/adminpack/Makefile (revision 14)
++++ contrib/adminpack/Makefile (local)
@@ -1,5 +1,5 @@
MODULE_big = adminpack
-PG_CPPFLAGS = -I$(libpq_srcdir)
@@ -58,11 +58,11 @@ index ba864c1..1e2e96e 100644
DATA_built = adminpack.sql
DATA = uninstall_adminpack.sql
DOCS = README.adminpack
-diff --git a/src/Makefile b/src/Makefile
-index 6d9043a..ccf7ae7 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -18,14 +18,11 @@ all install installdirs uninstall dep depend distprep:
+=== src/Makefile
+==================================================================
+--- src/Makefile (revision 14)
++++ src/Makefile (local)
+@@ -18,14 +18,11 @@
$(MAKE) -C timezone $@
$(MAKE) -C backend $@
$(MAKE) -C backend/utils/mb/conversion_procs $@
@@ -78,11 +78,11 @@ index 6d9043a..ccf7ae7 100644
install-local: installdirs-local
$(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
-diff --git a/src/Makefile.global.in b/src/Makefile.global.in
-index 820dfd5..2619acd 100644
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -365,10 +365,10 @@ endif
+=== src/Makefile.global.in
+==================================================================
+--- src/Makefile.global.in (revision 14)
++++ src/Makefile.global.in (local)
+@@ -365,10 +365,10 @@
submake-libpq:
@@ -95,11 +95,11 @@ index 820dfd5..2619acd 100644
.PHONY: submake-libpq submake-libpgport
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 0d86213..2779a41 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,8 +13,8 @@ subdir = src/bin
+=== src/bin/Makefile
+==================================================================
+--- src/bin/Makefile (revision 14)
++++ src/bin/Makefile (local)
+@@ -13,8 +13,8 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
@@ -110,11 +110,24 @@ index 0d86213..2779a41 100644
ifeq ($(PORTNAME), win32)
DIRS+=pgevent
endif
-diff --git a/src/port/Makefile b/src/port/Makefile
-index 1742eb8..21fd79f 100644
---- a/src/port/Makefile
-+++ b/src/port/Makefile
-@@ -29,11 +29,10 @@ LIBS += $(PTHREAD_LIBS)
+=== src/include/pg_config_manual.h
+==================================================================
+--- src/include/pg_config_manual.h (revision 14)
++++ src/include/pg_config_manual.h (local)
+@@ -175,7 +175,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+=== src/port/Makefile
+==================================================================
+--- src/port/Makefile (revision 14)
++++ src/port/Makefile (local)
+@@ -29,11 +29,10 @@
# Replace all object files so they use FRONTEND define
LIBOBJS_SRV := $(LIBOBJS:%.o=%_srv.o)
@@ -128,11 +141,11 @@ index 1742eb8..21fd79f 100644
installdirs:
$(mkinstalldirs) '$(DESTDIR)$(libdir)'
-diff --git a/src/test/regress/GNUmakefile b/src/test/regress/GNUmakefile
-index f2319d2..85aac4f 100644
---- a/src/test/regress/GNUmakefile
-+++ b/src/test/regress/GNUmakefile
-@@ -148,7 +148,7 @@ all-spi:
+=== src/test/regress/GNUmakefile
+==================================================================
+--- src/test/regress/GNUmakefile (revision 14)
++++ src/test/regress/GNUmakefile (local)
+@@ -148,7 +148,7 @@
check: all
-rm -rf ./testtablespace
mkdir ./testtablespace
@@ -141,11 +154,11 @@ index f2319d2..85aac4f 100644
installcheck: all
-rm -rf ./testtablespace
-diff --git a/src/test/regress/pg_regress.c b/src/test/regress/pg_regress.c
-index 5daf28a..0d2a0a3 100644
---- a/src/test/regress/pg_regress.c
-+++ b/src/test/regress/pg_regress.c
-@@ -502,7 +502,7 @@ initialize_environment(void)
+=== src/test/regress/pg_regress.c
+==================================================================
+--- src/test/regress/pg_regress.c (revision 14)
++++ src/test/regress/pg_regress.c (local)
+@@ -502,7 +502,7 @@
datadir = tmp;
/* psql will be installed into temp-install bindir */
@@ -154,7 +167,7 @@ index 5daf28a..0d2a0a3 100644
/*
* Set up shared library paths to include the temp install.
-@@ -1535,7 +1535,7 @@ main(int argc, char *argv[])
+@@ -1535,7 +1535,7 @@
*/
snprintf(buf, sizeof(buf),
SYSTEMQUOTE "\"%s/psql\" -X postgres <%s 2>%s" SYSTEMQUOTE,