summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-server/postgresql-server-7.4.19.ebuild')
-rw-r--r--dev-db/postgresql-server/postgresql-server-7.4.19.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild b/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
index 582fbf0..985fe62 100644
--- a/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
+++ b/dev-db/postgresql-server/postgresql-server-7.4.19.ebuild
@@ -83,14 +83,14 @@ src_compile() {
$(use_with python) \
$(use_with tcl) \
--with-includes="/usr/include/postgresql-${SLOT}/" \
- --with-libs="/usr/lib/postgresql-${SLOT}/lib/" \
+ --with-libs="/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)/" \
"$(built_with_use ~dev-db/postgresql-base-${PV} nls && use_enable nls nls "$(wanted_languages)")" \
"CFLAGS='${CFLAGS} $(use xml && pkg-config --cflags libxml-2.0)'" \
- "LIBS='${LIBS} $(use xml && pkg-config --libs libxml-2.0) -L/usr/lib/postgresql-${SLOT}/lib'" \
+ "LIBS='${LIBS} $(use xml && pkg-config --libs libxml-2.0) -L/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)'" \
|| die "configure failed"
for bd in . contrib $(use xml && echo contrib/xml) ; do
- PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
emake -C $bd -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" \
docdir=/usr/share/doc/${PF} SLOT=${SLOT} || die "emake in $bd failed"
done
@@ -104,7 +104,7 @@ src_install() {
fi
for bd in . contrib $(use xml && echo contrib/xml) ; do
- PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
emake install -C $bd -j1 DESTDIR="${D}" \
docdir=/usr/share/doc/${PF} SLOT=${SLOT} || die "emake install in $bd failed"
done
@@ -113,8 +113,8 @@ src_install() {
dodoc README HISTORY doc/{README.*,TODO,bug.template}
- dodir /usr/lib/eselect-postgresql/slots/${SLOT}
- cat >"${D}/usr/lib/eselect-postgresql/slots/${SLOT}/service" <<-__EOF__
+ dodir /usr/$(get_libdir)/eselect-postgresql/slots/${SLOT}
+ cat >"${D}/usr/$(get_libdir)/eselect-postgresql/slots/${SLOT}/service" <<-__EOF__
postgres_ebuilds="\${postgres_ebuilds} ${PF}"
postgres_service="postgresql-${SLOT}"
__EOF__
@@ -194,7 +194,7 @@ pkg_config() {
src_test() {
einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
- PATH="/usr/lib/postgresql-${SLOT}/bin:${PATH}" \
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
emake -j1 check \
PGXS=$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --pgxs) \
NO_PGXS=0 USE_PGXS=1 SLOT=${SLOT} || die "Make check failed. See above for details."