aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-08 17:12:29 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-08 17:12:29 +0200
commitda16f2db7690c6b34063fa3c07302f19ed7a6185 (patch)
tree3e7bff6d2b37f466482610527c5870907f9db24c /Makefile.gpyutils
parentpkgcheck: PkgMetadataXmlEmptyElement -> warn (diff)
downloadqa-scripts-da16f2db7690c6b34063fa3c07302f19ed7a6185.tar.gz
qa-scripts-da16f2db7690c6b34063fa3c07302f19ed7a6185.tar.bz2
qa-scripts-da16f2db7690c6b34063fa3c07302f19ed7a6185.zip
Add a Makefile to run gpyutils suite
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils80
1 files changed, 80 insertions, 0 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
new file mode 100644
index 0000000..3e8a9df
--- /dev/null
+++ b/Makefile.gpyutils
@@ -0,0 +1,80 @@
+export PACKAGE_MANAGER = pkgcore
+
+PORTDIR ?= $(shell pinspect query get_repo_path gentoo)
+timestamp = $(PORTDIR)/metadata/timestamp.commit
+# pass via make!
+outdir = /dev/null
+
+# upgrades for stable impls
+upgr_base = $(outdir)/34-to-35.txt $(outdir)/35-to-36.txt
+# related stabilizations
+upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
+# all upgrade stuff
+upgr_txt = $(upgr_base) $(upgr_streq) $(outdir)/pypy3-to-35.txt
+upgr_dot = $(patsubst %.txt,%.dot,$(upgr_txt))
+upgr_svg = $(patsubst %.dot,%.svg,$(upgr_dot))
+upgr_all = $(upgr_txt) $(upgr_dot) $(upgr_svg)
+
+all = $(upgr_all) $(outdir)/cands.txt $(outdir)/missing-meta.txt
+
+all: $(all)
+
+$(outdir)/cands.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-cands > $@.new
+ mv $@.new $@
+
+$(outdir)/depcands.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-depcands > $@.new
+ mv $@.new $@
+
+$(outdir)/depcands-all.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-depcands --all > $@.new
+ mv $@.new $@
+
+$(outdir)/depcheck.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-depcheck > $@.new
+ mv $@.new $@
+
+$(outdir)/34-to-35.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl python3_4 python3_5 > $@.new
+ mv $@.new $@
+
+$(outdir)/34-to-35-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -s python3_4 python3_5 > $@.new
+ mv $@.new $@
+
+$(outdir)/35-to-36.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl python3_5 python3_6 > $@.new
+ mv $@.new $@
+
+$(outdir)/35-to-36-stablereq.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl -s python3_5 python3_6 > $@.new
+ mv $@.new $@
+
+$(outdir)/pypy3-to-35.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-upgrade-impl pypy3 python3_5 > $@.new
+ mv $@.new $@
+
+$(outdir)/missing-meta.txt: $(timestamp)
+ mkdir -p $(outdir)
+ gpy-find-missing-meta > $@.new
+ mv $@.new $@
+
+%.dot: %.txt
+ gpy-depgraph -m python@gentoo.org $< > $@.new
+ mv $@.new $@
+
+%.svg: %.dot
+ dot -Tsvg $< > $@.new
+ mv $@.new $@
+
+.PHONY: all