aboutsummaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-08 01:52:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-08 01:54:42 +0200
commit6e9522c9a24039b565b690526211cd1c1c89a357 (patch)
treee59da1b17a28a42598a0fb024e1dd8cb91d120a2 /dev-qt
parentdev-qt/qtcore: remove IUSE=systemd (diff)
downloadqt-6e9522c9a24039b565b690526211cd1c1c89a357.tar.gz
qt-6e9522c9a24039b565b690526211cd1c1c89a357.tar.bz2
qt-6e9522c9a24039b565b690526211cd1c1c89a357.zip
dev-qt/qtlocation: Sync mapboxgl snapshot facility from ::gentoo
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.11.9999.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.15.11.9999.ebuild b/dev-qt/qtlocation/qtlocation-5.15.11.9999.ebuild
index badb3cba..0e9f034e 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.11.9999.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.11.9999.ebuild
@@ -5,12 +5,15 @@ EAPI=8
if [[ ${PV} != *9999* ]]; then
QT5_KDEPATCHSET_REV=1
+ MAPBOXGL_COMMIT=4c88f2c0e61daa89f584a8a9a3eba210221c6920
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
fi
inherit qt5-build
DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+[[ ${QT5_BUILD_TYPE} == release ]] &&
+SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz"
IUSE=""
@@ -39,6 +42,14 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+src_prepare() {
+ rm -rf src/3rdparty/mapbox-gl-native/* || die
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.