aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Documentation')
-rw-r--r--Documentation/maintainers/compare-ebuilds.sh47
1 files changed, 47 insertions, 0 deletions
diff --git a/Documentation/maintainers/compare-ebuilds.sh b/Documentation/maintainers/compare-ebuilds.sh
new file mode 100644
index 00000000..fb9002e6
--- /dev/null
+++ b/Documentation/maintainers/compare-ebuilds.sh
@@ -0,0 +1,47 @@
+#!/bin/bash
+
+#
+# Script for comparing release ebuilds against live ebuilds
+# Author: Markos Chandras <hwoarang@gentoo.org>
+#
+
+. /etc/init.d/functions.sh
+
+usage() {
+ echo
+ echo "./compare-ebuilds.sh <version you want to compare>"
+ echo
+}
+
+PORTDIR="$(portageq envvar PORTDIR)"
+OVERLAY=
+LIVE_VERSION="4.8.9999" # you normally don't need to change that
+
+#hacky way to find full path for qt overlay
+for prof in $(portageq portdir_overlay); do
+ grep -q "^qt$" ${prof}/profiles/repo_name
+ [[ $? == 0 ]] && OVERLAY=${prof} && break
+done
+
+[[ -z ${OVERLAY} ]] && \
+ echo "Can't find path for your Qt overlay" && \
+ exit 1
+
+[[ -z ${1} ]] && \
+ echo "Wrong number of parameters" && \
+ usage && exit 1
+
+for x in $(find ${PORTDIR}/x11-libs -type f -name "qt-*-${1}*.ebuild" -printf "%h\n"|uniq);do
+ diff -Naur $(find ${x} -type f -name "*-${1}*.ebuild") \
+ ${OVERLAY}/x11-libs/$(basename ${x})/$(basename ${x})-${LIVE_VERSION}.ebuild
+ if [[ $? != 0 ]]; then
+ einfo "Press enter if you want to move to the next ebuild"
+ einfo "or 'n' if you want to stop now!"
+ read resp
+ [[ ${resp} == "n" ]] && exit 1
+ fi
+done
+
+einfo "Sweet! All done!"
+
+exit 0