aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-22 23:11:46 -0500
committerMike Frysinger <vapier@gentoo.org>2014-02-24 02:49:49 -0500
commit13469f866572bd9550a70d22abe1e88593388eef (patch)
tree835eca9f7ff9b56e4dd9517be674efbdabc33786 /tools/catalyst-auto-s390x.conf
parentcatalyst-auto: run in a mount namespace (diff)
downloadreleng-13469f866572bd9550a70d22abe1e88593388eef.tar.gz
releng-13469f866572bd9550a70d22abe1e88593388eef.tar.bz2
releng-13469f866572bd9550a70d22abe1e88593388eef.zip
add autobuild support for s390/s390x
Diffstat (limited to 'tools/catalyst-auto-s390x.conf')
-rw-r--r--tools/catalyst-auto-s390x.conf54
1 files changed, 54 insertions, 0 deletions
diff --git a/tools/catalyst-auto-s390x.conf b/tools/catalyst-auto-s390x.conf
new file mode 100644
index 00000000..c085330f
--- /dev/null
+++ b/tools/catalyst-auto-s390x.conf
@@ -0,0 +1,54 @@
+# This is the config file for the catalyst-auto script. It should be pretty
+# self-explanatory.
+
+GITDIR=/root/releng/
+
+SPECS_DIR=${GITDIR}/releases/weekly/specs/s390/s390x
+SUBARCH=`grep subarch $SPECS_DIR/stage1.spec | awk '{print $2}'`
+
+SETS="default"
+
+SET_default_SPECS="stage1.spec stage2.spec stage3.spec"
+
+#KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/s390
+
+EMAIL_TO=releng@gentoo.org,gentoo-releng-autobuilds@lists.gentoo.org
+EMAIL_FROM=catalyst@$(hostname)
+EMAIL_SUBJECT_PREPEND="[${SUBARCH}-auto]"
+
+
+CATALYST_CONFIG=/etc/catalyst/catalyst.conf
+
+BUILD_SRCDIR_BASE=`grep storedir= $CATALYST_CONFIG | cut -d '=' -f2 | sed -e 's/"//g'`
+
+give_latest_from_dates() {
+ sed 's,-20,~20,g' | \
+ sort -k +1 -n -t '~' |\
+ awk -F\~ \
+ 'BEGIN{i=$1; o=$0};
+ { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
+ END { print o; };' | \
+ tr '~' '-'
+}
+
+
+pre_build() {
+ cd ${GITDIR}
+ git pull
+
+ # Symlink the latest stages3 to build from
+ for d in ${BUILD_SRCDIR_BASE}/builds/default ; do
+ pushd $d
+ for f in $(ls stage3-${SUBARCH}-*bz2 | grep -v latest | give_latest_from_dates ) ; do
+ of=${f/20[0-9][0-9].[0-9]/latest} # for 20XX.Y stuff
+ of=${of/20[0-9][0-9][0-1][0-9][0-9][0-9]/latest} # for $
+ ln -sf $f $of
+ done
+ popd
+ done
+}
+
+
+post_build() {
+ rsync -e 'ssh -i /root/.ssh/id_rsa' ${BUILD_SRCDIR_BASE}/builds/default/stage3-${SUBARCH}-*${DATESTAMP}*.tar.bz2* s390@skimmer.gentoo.org:
+}