summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2017-07-23 10:56:47 +0200
committerHans de Graaff <hans@degraaff.org>2017-07-23 10:56:47 +0200
commitd6ddc8a3fc527a644e28937d95f555d51e1c7e55 (patch)
tree00f82f5389bf7e2f7c44cb188de94cbb67fbc61c
parentUpdate VERSION for new release (diff)
downloadruby-scripts-d6ddc8a3fc527a644e28937d95f555d51e1c7e55.tar.gz
ruby-scripts-d6ddc8a3fc527a644e28937d95f555d51e1c7e55.tar.bz2
ruby-scripts-d6ddc8a3fc527a644e28937d95f555d51e1c7e55.zip
Patch set for 2.2.7-r3
Add net-smtp-validation patch.
-rw-r--r--patchsets/patches-2.2.7-r3/001_ia64.patch62
-rw-r--r--patchsets/patches-2.2.7-r3/004_gfbsd7.patch37
-rw-r--r--patchsets/patches-2.2.7-r3/005_no-undefined-ext.patch11
-rw-r--r--patchsets/patches-2.2.7-r3/006_tcltk1.patch27
-rw-r--r--patchsets/patches-2.2.7-r3/007_tcltk2.patch110
-rw-r--r--patchsets/patches-2.2.7-r3/008-net-smtp-validation.patch39
-rw-r--r--patchsets/patches-2.2.7-r3/009_no-gems.patch88
7 files changed, 374 insertions, 0 deletions
diff --git a/patchsets/patches-2.2.7-r3/001_ia64.patch b/patchsets/patches-2.2.7-r3/001_ia64.patch
new file mode 100644
index 0000000..e1e9c89
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/001_ia64.patch
@@ -0,0 +1,62 @@
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=561780
+
+fix crash on register stack mark/sweep pass
+
+The crash looks like
+
+ Program received signal SIGSEGV, Segmentation fault.
+ mark_locations_array (objspace=0x6000000000045db0, x=0x0, n=864692227966763116) at gc.c:3297
+ 3297 v = *x;
+ (gdb) bt
+ #0 mark_locations_array (objspace=0x6000000000045db0, x=0x0, n=864692227966763116) at gc.c:3297
+ #1 0x400000000014a040 in gc_mark_locations (objspace=0x6000000000045db0, start=0x0, end=0x6000080000000368) at gc.c:3310
+ #2 0x400000000014b3a0 in mark_current_machine_context (objspace=0x6000000000045db0, th=0x60000000000455b0) at gc.c:3500
+ #3 0x400000000014dfe0 in gc_mark_roots (objspace=0x6000000000045db0, full_mark=0, categoryp=0x0) at gc.c:4105
+ #4 0x400000000014e6b0 in gc_marks_body (objspace=0x6000000000045db0, full_mark=0) at gc.c:4164
+ #5 0x400000000014f260 in gc_marks (objspace=0x6000000000045db0, full_mark=0) at gc.c:4526
+ #6 0x40000000001525c0 in garbage_collect_body (objspace=0x6000000000045db0, full_mark=0, immediate_sweep=0, reason=256) at gc.c:5024
+ #7 0x400000000013c010 in heap_prepare_freepage (objspace=0x6000000000045db0, heap=0x6000000000045dc0) at gc.c:1219
+ #8 0x400000000013c140 in heap_get_freeobj_from_next_freepage (objspace=0x6000000000045db0, heap=0x6000000000045dc0) at gc.c:1237
+ #9 0x400000000013c360 in heap_get_freeobj (objspace=0x6000000000045db0, heap=0x6000000000045dc0) at gc.c:1259
+ #10 0x400000000013c950 in newobj_of (klass=0, flags=40, v1=0, v2=0, v3=0) at gc.c:1303
+ #11 0x400000000013ccc0 in rb_newobj_of (klass=0, flags=40) at gc.c:1356
+ #12 0x4000000000163740 in hash_alloc (klass=0) at hash.c:289
+ #13 0x4000000000163860 in rb_hash_new () at hash.c:309
+ #14 0x400000000050e420 in Init_BareVM () at vm.c:2822
+ #15 0x40000000000f6b60 in ruby_setup () at eval.c:54
+ #16 0x40000000000f6f50 in ruby_init () at eval.c:75
+ #17 0x400000000001b010 in main (argc=9, argv=0x60000fffffffb1d8) at main.c:35
+
+The problem here is in call
+ gc_mark_locations (objspace=0x6000000000045db0, start=0x0, end=0x6000080000000368) at gc.c:3310
+where 'start' (native_main_thread.register_stack_start)
+is supposed to be stack start but it's not initialized.
+
+The initialization of 'native_main_thread.register_stack_start'
+is supposed to be done in 'ruby_init_stack()'.
+
+But code under 'MAINSTACKADDR_AVAILABLE' exits early.
+The fix is to move 'register_stack_start' earlier.
+
+diff --git a/thread_pthread.c b/thread_pthread.c
+index c8a7a16..9ad448b 100644
+--- a/thread_pthread.c
++++ b/thread_pthread.c
+@@ -722,2 +722,8 @@ ruby_init_stack(volatile VALUE *addr
+ native_main_thread.id = pthread_self();
++#ifdef __ia64
++ if (!native_main_thread.register_stack_start ||
++ (VALUE*)bsp < native_main_thread.register_stack_start) {
++ native_main_thread.register_stack_start = (VALUE*)bsp;
++ }
++#endif
+ #if MAINSTACKADDR_AVAILABLE
+@@ -745,8 +751,2 @@ ruby_init_stack(volatile VALUE *addr
+ #endif
+-#ifdef __ia64
+- if (!native_main_thread.register_stack_start ||
+- (VALUE*)bsp < native_main_thread.register_stack_start) {
+- native_main_thread.register_stack_start = (VALUE*)bsp;
+- }
+-#endif
+ {
diff --git a/patchsets/patches-2.2.7-r3/004_gfbsd7.patch b/patchsets/patches-2.2.7-r3/004_gfbsd7.patch
new file mode 100644
index 0000000..450d714
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/004_gfbsd7.patch
@@ -0,0 +1,37 @@
+--- configure.in.orig 2013-05-05 19:36:02.800254192 +0200
++++ configure.in 2013-05-05 19:37:56.573346196 +0200
+@@ -2156,7 +2156,7 @@
+ fi
+
+ AS_CASE(["$target_os"],
+-[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl], [
++[linux* | gnu* | k*bsd*-gnu | bsdi* | kopensolaris*-gnu | nacl | freebsd* | dragonfly*], [
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -2249,7 +2249,7 @@
+ [bsdi3*], [ AS_CASE(["$CC"],
+ [*shlicc*], [ : ${LDSHARED='$(CC) -r'}
+ rb_cv_dlopen=yes])],
+- [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu | freebsd7*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -2262,7 +2262,6 @@
+ [freebsd*|dragonfly*], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+@@ -2638,7 +2637,7 @@
+ [sunos4*], [
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ],
+- [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu], [
++ [linux* | gnu* | k*bsd*-gnu | atheos* | kopensolaris*-gnu | freebsd7*], [
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'" $LDFLAGS_OPTDIR"
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ if test "$load_relative" = yes; then
diff --git a/patchsets/patches-2.2.7-r3/005_no-undefined-ext.patch b/patchsets/patches-2.2.7-r3/005_no-undefined-ext.patch
new file mode 100644
index 0000000..f279932
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/005_no-undefined-ext.patch
@@ -0,0 +1,11 @@
+--- ruby-1.9.3-preview1.orig/configure.in
++++ ruby-1.9.3-preview1/configure.in
+@@ -2038,7 +2038,7 @@ if test "$with_dln_a_out" != yes; then
+ [linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | kopensolaris*-gnu], [
+ : ${LDSHARED='$(CC) -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes],
+ [interix*], [ : ${LDSHARED='$(CC) -shared'}
diff --git a/patchsets/patches-2.2.7-r3/006_tcltk1.patch b/patchsets/patches-2.2.7-r3/006_tcltk1.patch
new file mode 100644
index 0000000..a0e7444
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/006_tcltk1.patch
@@ -0,0 +1,27 @@
+From ebd0fc80d62eeb7b8556522256f8d035e013eb65 Mon Sep 17 00:00:00 2001
+From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
+Date: Sun, 2 Aug 2015 01:27:31 +0000
+Subject: [PATCH] tcltklib.c: check argument
+
+* ext/tk/tcltklib.c (ip_cancel_eval_core): check argument type and
+ length.
+
+git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@51468 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
+---
+ ext/tk/tcltklib.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/ext/tk/tcltklib.c b/ext/tk/tcltklib.c
+index afcee3b..e305c13 100644
+--- a/ext/tk/tcltklib.c
++++ b/ext/tk/tcltklib.c
+@@ -7745,7 +7745,8 @@ ip_cancel_eval_core(interp, msg, flag)
+ if (NIL_P(msg)) {
+ msg_obj = NULL;
+ } else {
+- msg_obj = Tcl_NewStringObj(RSTRING_PTR(msg), RSTRING_LEN(msg));
++ char *s = StringValuePtr(msg);
++ msg_obj = Tcl_NewStringObj(s, RSTRING_LENINT(msg));
+ Tcl_IncrRefCount(msg_obj);
+ }
+
diff --git a/patchsets/patches-2.2.7-r3/007_tcltk2.patch b/patchsets/patches-2.2.7-r3/007_tcltk2.patch
new file mode 100644
index 0000000..2357898
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/007_tcltk2.patch
@@ -0,0 +1,110 @@
+From d098136e3f62a4879a7d7cd34bbd50f482ba3331 Mon Sep 17 00:00:00 2001
+From: nobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
+Date: Tue, 9 Aug 2016 05:05:11 +0000
+Subject: [PATCH] tcltklib.c: use StringValueCStr [ci skip]
+
+* ext/tk/tcltklib.c (set_max_block_time, tcl_protect_core,
+ ip_init, ip_create_slave_core, get_obj_from_str,
+ ip_cancel_eval_core, lib_set_system_encoding,
+ alloc_invoke_arguments, lib_merge_tklist): use StringValueCStr
+ instead of StringValuePtr for values to be passed to Tcl
+ interperter.
+
+git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@55842 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
+---
+ ext/tk/tcltklib.c | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/ext/tk/tcltklib.c b/ext/tk/tcltklib.c
+index 430c934..721f497 100644
+--- a/ext/tk/tcltklib.c
++++ b/ext/tk/tcltklib.c
+@@ -3303,7 +3303,7 @@ tcl_protect_core(interp, proc, data) /* should not raise exception */
+ DUMP1("set backtrace");
+ if (!NIL_P(backtrace = rb_funcallv(exc, ID_backtrace, 0, 0))) {
+ backtrace = rb_ary_join(backtrace, rb_str_new2("\n"));
+- Tcl_AddErrorInfo(interp, StringValuePtr(backtrace));
++ Tcl_AddErrorInfo(interp, StringValueCStr(backtrace));
+ }
+
+ rb_thread_critical = thr_crit_bup;
+@@ -6208,19 +6208,19 @@ ip_init(argc, argv, self)
+ /* without Tk */
+ with_tk = 0;
+ } else {
+- /* Tcl_SetVar(ptr->ip, "argv", StringValuePtr(opts), 0); */
+- Tcl_SetVar(ptr->ip, "argv", StringValuePtr(opts), TCL_GLOBAL_ONLY);
++ /* Tcl_SetVar(ptr->ip, "argv", StringValueCStr(opts), 0); */
++ Tcl_SetVar(ptr->ip, "argv", StringValueCStr(opts), TCL_GLOBAL_ONLY);
+ Tcl_Eval(ptr->ip, "set argc [llength $argv]");
+ }
+ case 1:
+ /* argv0 */
+ if (!NIL_P(argv0)) {
+- if (strncmp(StringValuePtr(argv0), "-e", 3) == 0
+- || strncmp(StringValuePtr(argv0), "-", 2) == 0) {
++ if (strncmp(StringValueCStr(argv0), "-e", 3) == 0
++ || strncmp(StringValueCStr(argv0), "-", 2) == 0) {
+ Tcl_SetVar(ptr->ip, "argv0", "ruby", TCL_GLOBAL_ONLY);
+ } else {
+- /* Tcl_SetVar(ptr->ip, "argv0", StringValuePtr(argv0), 0); */
+- Tcl_SetVar(ptr->ip, "argv0", StringValuePtr(argv0),
++ /* Tcl_SetVar(ptr->ip, "argv0", StringValueCStr(argv0), 0); */
++ Tcl_SetVar(ptr->ip, "argv0", StringValueCStr(argv0),
+ TCL_GLOBAL_ONLY);
+ }
+ }
+@@ -6420,7 +6420,7 @@ ip_create_slave_core(interp, argc, argv)
+ slave->allow_ruby_exit = 0;
+ slave->return_value = 0;
+
+- slave->ip = Tcl_CreateSlave(master->ip, StringValuePtr(name), safe);
++ slave->ip = Tcl_CreateSlave(master->ip, StringValueCStr(name), safe);
+ if (slave->ip == NULL) {
+ rb_thread_critical = thr_crit_bup;
+ return rb_exc_new2(rb_eRuntimeError,
+@@ -6896,7 +6896,7 @@ static Tcl_Obj *
+ get_obj_from_str(str)
+ VALUE str;
+ {
+- const char *s = StringValuePtr(str);
++ const char *s = StringValueCStr(str);
+
+ #if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 0
+ return Tcl_NewStringObj((char*)s, RSTRING_LEN(str));
+@@ -7744,7 +7744,7 @@ ip_cancel_eval_core(interp, msg, flag)
+ if (NIL_P(msg)) {
+ msg_obj = NULL;
+ } else {
+- char *s = StringValuePtr(msg);
++ char *s = StringValueCStr(msg);
+ msg_obj = Tcl_NewStringObj(s, RSTRING_LENINT(msg));
+ Tcl_IncrRefCount(msg_obj);
+ }
+@@ -8409,7 +8409,7 @@ lib_set_system_encoding(self, enc_name)
+
+ enc_name = rb_funcallv(enc_name, ID_to_s, 0, 0);
+ if (Tcl_SetSystemEncoding((Tcl_Interp *)NULL,
+- StringValuePtr(enc_name)) != TCL_OK) {
++ StringValueCStr(enc_name)) != TCL_OK) {
+ rb_raise(rb_eArgError, "unknown encoding name '%s'",
+ RSTRING_PTR(enc_name));
+ }
+@@ -8850,7 +8850,7 @@ alloc_invoke_arguments(argc, argv)
+ Tcl_Preserve((ClientData)av); /* XXXXXXXX */
+ #endif
+ for (i = 0; i < argc; ++i) {
+- av[i] = strdup(StringValuePtr(argv[i]));
++ av[i] = strdup(StringValueCStr(argv[i]));
+ }
+ av[argc] = NULL;
+ #endif
+@@ -9854,7 +9854,7 @@ lib_merge_tklist(argc, argv, obj)
+ len = 1;
+ for(num = 0; num < argc; num++) {
+ if (OBJ_TAINTED(argv[num])) taint_flag = 1;
+- dst = StringValuePtr(argv[num]);
++ dst = StringValueCStr(argv[num]);
+ #if TCL_MAJOR_VERSION >= 8
+ len += Tcl_ScanCountedElement(dst, RSTRING_LENINT(argv[num]),
+ &flagPtr[num]) + 1;
diff --git a/patchsets/patches-2.2.7-r3/008-net-smtp-validation.patch b/patchsets/patches-2.2.7-r3/008-net-smtp-validation.patch
new file mode 100644
index 0000000..0b30c99
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/008-net-smtp-validation.patch
@@ -0,0 +1,39 @@
+From 0827a7e52ba3d957a634b063bf5a391239b9ffee Mon Sep 17 00:00:00 2001
+From: shugo <shugo@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>
+Date: Wed, 8 Jun 2016 07:06:57 +0000
+Subject: [PATCH] * lib/net/smtp.rb (getok, get_response): raise an
+ ArgumentError when CR or LF is included in a line, because they are not
+ allowed in RFC5321.
+
+git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@55324 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
+---
+ lib/net/smtp.rb | 9 +++++++++
+
+diff --git a/lib/net/smtp.rb b/lib/net/smtp.rb
+index 250293bdbe21..a7130a593b40 100644
+--- a/lib/net/smtp.rb
++++ b/lib/net/smtp.rb
+@@ -926,7 +926,15 @@ def quit
+
+ private
+
++ def validate_line(line)
++ # A bare CR or LF is not allowed in RFC5321.
++ if /[\r\n]/ =~ line
++ raise ArgumentError, "A line must not contain CR or LF"
++ end
++ end
++
+ def getok(reqline)
++ validate_line reqline
+ res = critical {
+ @socket.writeline reqline
+ recv_response()
+@@ -936,6 +944,7 @@ def getok(reqline)
+ end
+
+ def get_response(reqline)
++ validate_line reqline
+ @socket.writeline reqline
+ recv_response()
+ end
diff --git a/patchsets/patches-2.2.7-r3/009_no-gems.patch b/patchsets/patches-2.2.7-r3/009_no-gems.patch
new file mode 100644
index 0000000..a67cbf8
--- /dev/null
+++ b/patchsets/patches-2.2.7-r3/009_no-gems.patch
@@ -0,0 +1,88 @@
+--- tool/rbinstall.rb.~1~ 2015-03-25 04:33:14.000000000 +0100
++++ tool/rbinstall.rb 2015-04-14 07:07:01.169073427 +0200
+@@ -654,83 +654,11 @@
+ # :startdoc:
+
+ install?(:ext, :comm, :gem) do
+- $:.unshift(File.join(srcdir, "lib"))
+- require("rubygems.rb")
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "default gems", gem_dir, directories
+-
+- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
+- default_spec_dir = "#{spec_dir}/default"
+- makedirs(default_spec_dir)
+-
+- gems = {}
+- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
+- line.chomp!
+- line.sub!(/\s*#.*/, '')
+- next if line.empty?
+- words = []
+- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
+- words << ($2 ? $2.split : $1)
+- end
+- name, base_dir, src, execs = *words
+- next unless name and base_dir and src
+-
+- src = File.join(srcdir, src)
+- base_dir = File.join(srcdir, base_dir)
+- specgen = RbInstall::Specs::Generator.new(name, base_dir, src, execs || [])
+- gems[name] ||= specgen
+- end
+-
+- Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").each do |src|
+- specgen = RbInstall::Specs::Reader.new(src)
+- gems[specgen.gemspec.name] ||= specgen
+- end
+-
+- gems.sort.each do |name, specgen|
+- gemspec = specgen.gemspec
+- base_dir = specgen.src.sub(/\A#{Regexp.escape(srcdir)}\//, "")
+- full_name = "#{gemspec.name}-#{gemspec.version}"
+-
+- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
+- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
+- open_for_install(gemspec_path, $data_mode) do
+- specgen.spec_source
+- end
+-
+- unless gemspec.executables.empty? then
+- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
+- makedirs(bin_dir)
+-
+- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
+- install(execs, bin_dir, :mode => $prog_mode)
+- end
+- end
++ # gems are unbundled in Gentoo.
+ end
+
+ install?(:ext, :comm, :gem) do
+- begin
+- require "zlib"
+- rescue LoadError
+- end
+- if defined?(Zlib)
+- require 'pathname'
+- gem_dir = Gem.default_dir
+- directories = Gem.ensure_gem_subdirectories(gem_dir, :mode => $dir_mode)
+- prepare "bundle gems", gem_dir, directories
+- Dir.glob(srcdir+'/gems/*.gem').each do |gem|
+- Gem.install gem, Gem::Requirement.default, :install_dir => with_destdir(Gem.dir), :domain => :local, :ignore_dependencies => true
+- gemname = Pathname(gem).basename
+- puts "#{" "*30}#{gemname}"
+- end
+- # fix directory permissions
+- # TODO: Gem.install should accept :dir_mode option or something
+- File.chmod($dir_mode, *Dir.glob(with_destdir(Gem.dir)+"/**/"))
+- # fix .gemspec permissions
+- File.chmod($data_mode, *Dir.glob(with_destdir(Gem.dir)+"/specifications/*.gemspec"))
+- else
+- puts "skip installing bundle gems because of lacking zlib"
+- end
++ # gems are unbundled in Gentoo.
+ end
+
+ parse_args()