aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman.sh5
-rwxr-xr-xbin/tinder.sh7
2 files changed, 5 insertions, 7 deletions
diff --git a/bin/repoman.sh b/bin/repoman.sh
index 32e9fc9..f76d514 100755
--- a/bin/repoman.sh
+++ b/bin/repoman.sh
@@ -23,7 +23,7 @@ function REPOMAN() {
repoman full > /tmp/repoman_log_current || true
if [[ "$NEXT_TARGET" != 'unknown' ]]; then
- sed -i -e "/^USE_RUBY/s/$CURR_TARGET/$CURR_TARGET $NEXT_TARGET/" "$NAME-$VERSION.ebuild"
+ sed -i -e "/^USE_RUBY/s/=\"/=\"$NEXT_TARGET /" "$NAME-$VERSION.ebuild"
repoman manifest
repoman full > /tmp/repoman_log_next || true
fi
@@ -63,8 +63,7 @@ else
VERSION="${PKG_ARR[2]}-${PKG_ARR[3]}"
fi
-CURR_TARGET=$2
-NEXT_TARGET=$3
+NEXT_TARGET=$2
SETUP
REPOMAN
CLEANUP
diff --git a/bin/tinder.sh b/bin/tinder.sh
index 4c75533..6e78e54 100755
--- a/bin/tinder.sh
+++ b/bin/tinder.sh
@@ -35,7 +35,7 @@ function SETUP () {
(
cd "$SCRIPT_DIR/overlay/$CATEGORY/$NAME"
- sed -i -e "/^USE_RUBY/s/$CURR_TARGET/$CURR_TARGET $NEXT_TARGET/" "$NAME-$VERSION.ebuild"
+ sed -i -e "/^USE_RUBY/s/=\"/=\"$NEXT_TARGET /" "$NAME-$VERSION.ebuild"
repoman manifest
repoman full
)
@@ -113,7 +113,7 @@ if [[ $# -eq 1 ]]; then
SETUP
EMERGE
CLEANUP
-elif [[ $# -eq 3 ]]; then
+elif [[ $# -eq 2 ]]; then
TYPE="current_target"
PACKAGE=$1
SETUP
@@ -122,8 +122,7 @@ elif [[ $# -eq 3 ]]; then
TYPE="next_target"
PACKAGE=$1
- CURR_TARGET=$2
- NEXT_TARGET=$3
+ NEXT_TARGET=$2
SETUP
EMERGE
CLEANUP