aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-07-30 11:34:27 -0400
committerHorea Christian <chr@chymera.eu>2024-07-30 11:34:27 -0400
commite4579f5851734f245b02cc1e98f3b69d9df67e09 (patch)
tree5059983587d1aeda01e747e47812cc65ce40b22c
parentdev-python/pynwb: drop 2.5.0 (diff)
downloadsci-e4579f5851734f245b02cc1e98f3b69d9df67e09.tar.gz
sci-e4579f5851734f245b02cc1e98f3b69d9df67e09.tar.bz2
sci-e4579f5851734f245b02cc1e98f3b69d9df67e09.zip
dev-python/nwb2bids: new package, add 0.0.3
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/nwb2bids/Manifest1
-rw-r--r--dev-python/nwb2bids/metadata.xml15
-rw-r--r--dev-python/nwb2bids/nwb2bids-0.0.3.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/nwb2bids/Manifest b/dev-python/nwb2bids/Manifest
new file mode 100644
index 000000000..5e85ba08f
--- /dev/null
+++ b/dev-python/nwb2bids/Manifest
@@ -0,0 +1 @@
+DIST nwb2bids-0.0.3.tar.gz 7054 BLAKE2B 0ebd50a557dea2fb878247d28949e287722cd71a43bd477a404dfbe1d999e94d1aff0421c4e338a354e5f09a3aee8b9258a2191ae6a108c32ed4f56b650b9d39 SHA512 9df9efecb39b55e2712ce825950e472cbe9e076e6901ab44d84f7cbb23c1f7c9b1f0ae71a5684adeae61d42662ee288c5464db0ff616888aadc4fd08549dc85b
diff --git a/dev-python/nwb2bids/metadata.xml b/dev-python/nwb2bids/metadata.xml
new file mode 100644
index 000000000..6dc951583
--- /dev/null
+++ b/dev-python/nwb2bids/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">con/nwb2bids</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild b/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild
new file mode 100644
index 000000000..5f778356e
--- /dev/null
+++ b/dev-python/nwb2bids/nwb2bids-0.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Next-generation file format (NGFF) for storing bioimaging data in the cloud"
+HOMEPAGE="https://github.com/con/nwb2bids"
+SRC_URI="https://github.com/con/nwb2bids/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ test? (
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest