aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2021-01-05 01:32:05 -0500
committerHorea Christian <chr@chymera.eu>2021-01-05 01:32:05 -0500
commit037b1acf3fabc6e412d2313e9aedd79e9597fd8f (patch)
tree2257570eff4baa5b97f790ab006cb9076917ba24 /app-office
parentprofiles/package.mask unmask quast and and pysamstats: fixed (diff)
downloadsci-037b1acf3fabc6e412d2313e9aedd79e9597fd8f.tar.gz
sci-037b1acf3fabc6e412d2313e9aedd79e9597fd8f.tar.bz2
sci-037b1acf3fabc6e412d2313e9aedd79e9597fd8f.zip
app-office/visidata: new package
prospectively ahead of ::gentoo https://github.com/gentoo/gentoo/pull/15889 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/visidata/Manifest1
-rw-r--r--app-office/visidata/metadata.xml22
-rw-r--r--app-office/visidata/visidata-1.5.2.ebuild60
3 files changed, 83 insertions, 0 deletions
diff --git a/app-office/visidata/Manifest b/app-office/visidata/Manifest
new file mode 100644
index 000000000..23e0d08fc
--- /dev/null
+++ b/app-office/visidata/Manifest
@@ -0,0 +1 @@
+DIST visidata-1.5.2.tar.gz 637598 BLAKE2B 47ef05280cec9fdb3620759b7c2089de7d2e42a4a1d1a13d14b5e59555c8de6091ceab1fb72ab4ee45dc7611741ffdc6eeefcab5e4755485b6d18d48327fe639 SHA512 36f11c207f391d06095dfab75fe4a638e562cd20bc29f72a6e5df1dcc87ab46f2834ffbdb561fb9e4e07fdd50dc5b34c619bbc4bc3d34ce350428e7330ea252c
diff --git a/app-office/visidata/metadata.xml b/app-office/visidata/metadata.xml
new file mode 100644
index 000000000..baa3633f0
--- /dev/null
+++ b/app-office/visidata/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chr@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ VisiData is an interactive multitool for tabular data. It combines the
+ clarity of a spreadsheet, the efficiency of the terminal, and the power
+ of Python, into a lightweight utility which can handle millions of rows
+ with ease.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">saulpw/visidata</remote-id>
+ <remote-id type="pypi">visidata</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/visidata/visidata-1.5.2.ebuild b/app-office/visidata/visidata-1.5.2.ebuild
new file mode 100644
index 000000000..b2cb42633
--- /dev/null
+++ b/app-office/visidata/visidata-1.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Terminal spreadsheet multitool for discovering and arranging data"
+HOMEPAGE="http://visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND=""
+BDEPEND="
+ test? (
+ dev-vcs/git
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ rm tests/golden/load-http.tsv || die "Could not remove network-dependent test."
+ git init || die "Git init failed."
+ git add tests/golden/ || die "Git add failed."
+ dev/test.sh || die "Tests failed."
+ rm .git -rf || die "Could not clean up git test directory."
+}
+
+pkg_postinst() {
+ optfeature "integration with yaml" dev-python/pyyaml
+ optfeature "integration with pcap" dev-python/dnslib #dpkt pypcapkit
+ optfeature "integration with png" dev-python/pypng
+ optfeature "integration with http" dev-python/requests
+ optfeature "integration with postgres" dev-python/psycopg
+ optfeature "integration with xlsx" dev-python/openpyxl
+ optfeature "integration with xls" dev-python/xlrd
+ optfeature "integration with hdf5" dev-python/h5py
+ optfeature "integration with ttf/otf" dev-python/fonttools
+ optfeature "integration with xml/htm/html" dev-python/lxml
+ optfeature "integration with dta (Stata)" dev-python/pandas
+ optfeature "integration with shapefiles" sci-libs/pyshp
+ optfeature "integration with namestand" dev-python/graphviz
+ #optfeature "integration with mbtiles" mapbox-vector-tile
+ #optfeature "integration with xpt (SAS)" xport
+ #optfeature "integration with sas7bdat (SAS)" sas7bdat
+ #optfeature "integration with sav (SPSS)" savReaderWriter
+}