aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2014-01-03 13:44:41 -0700
committerNicolas Bock <nicolasbock@gmail.com>2014-01-03 13:44:41 -0700
commit173bda9767c874d31218b53a2f640729bec406a6 (patch)
tree64621071da94c681961cdfdf08127bf2146bf543 /app-text
parentapp-text/jabref: Fix bug in java-pkg_getjars; use a '-' instead of ':' to spe... (diff)
downloadsci-173bda9767c874d31218b53a2f640729bec406a6.tar.gz
sci-173bda9767c874d31218b53a2f640729bec406a6.tar.bz2
sci-173bda9767c874d31218b53a2f640729bec406a6.zip
app-text/jabref: Do not remove unjarlib target yet.
We need to first replace all bundled libs with portage versions. Package-Manager: portage-2.2.7
Diffstat (limited to 'app-text')
-rw-r--r--app-text/jabref/ChangeLog5
-rw-r--r--app-text/jabref/jabref-2.10_beta-r1.ebuild5
-rw-r--r--app-text/jabref/jabref-2.10_beta2-r1.ebuild6
3 files changed, 11 insertions, 5 deletions
diff --git a/app-text/jabref/ChangeLog b/app-text/jabref/ChangeLog
index 241894a7a..1f1a32c3d 100644
--- a/app-text/jabref/ChangeLog
+++ b/app-text/jabref/ChangeLog
@@ -4,6 +4,11 @@
03 Jan 2014; Nicolas Bock <nicolasbock@gentoo.org> jabref-2.10_beta-r1.ebuild,
jabref-2.10_beta2-r1.ebuild:
+ app-text/jabref: Do not remove unjarlib target yet. We need to first replace
+ all bundled libs with portage versions.
+
+ 03 Jan 2014; Nicolas Bock <nicolasbock@gentoo.org> jabref-2.10_beta-r1.ebuild,
+ jabref-2.10_beta2-r1.ebuild:
app-text/jabref: Fix bug in java-pkg_getjars; use a '-' instead of ':' to
specify slot.
diff --git a/app-text/jabref/jabref-2.10_beta-r1.ebuild b/app-text/jabref/jabref-2.10_beta-r1.ebuild
index a69c70794..e8cd8a123 100644
--- a/app-text/jabref/jabref-2.10_beta-r1.ebuild
+++ b/app-text/jabref/jabref-2.10_beta-r1.ebuild
@@ -39,8 +39,9 @@ java_prepare() {
rm lib/fontbox*.jar || die
rm lib/spin.jar || die
- # Remove unjarlib target.
- sed -i -e 's:depends="build, unjarlib":depends="build":' build.xml
+ # Remove unjarlib target (do this only once we have removed all
+ # bundled dependencies in lib).
+ #sed -i -e 's:depends="build, unjarlib":depends="build":' build.xml
}
src_compile() {
diff --git a/app-text/jabref/jabref-2.10_beta2-r1.ebuild b/app-text/jabref/jabref-2.10_beta2-r1.ebuild
index c61af746a..e8cd8a123 100644
--- a/app-text/jabref/jabref-2.10_beta2-r1.ebuild
+++ b/app-text/jabref/jabref-2.10_beta2-r1.ebuild
@@ -39,15 +39,15 @@ java_prepare() {
rm lib/fontbox*.jar || die
rm lib/spin.jar || die
- # Remove unjarlib target.
- sed -i -e 's:depends="build, unjarlib":depends="build":' build.xml
+ # Remove unjarlib target (do this only once we have removed all
+ # bundled dependencies in lib).
+ #sed -i -e 's:depends="build, unjarlib":depends="build":' build.xml
}
src_compile() {
local EXTERNAL_JARS="fontbox-1.7,spin"
local CLASSPATH="$(java-pkg_getjars --with-dependencies ${EXTERNAL_JARS})"
eant \
- -verbose \
-Dgentoo.classpath=${CLASSPATH} \
jars \
$(usex doc docs "")