aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-23 05:39:35 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-12-23 05:39:35 +0000
commit856d88d5b61462241a36dcd90ad2b42b5a95a4d9 (patch)
tree17cd3b77d3009407d6f5ff110b1894b459374492 /sci-libs/ensmallen
parentdev-python/ripser: version bump to 0.6.0 (diff)
downloadsci-856d88d5b61462241a36dcd90ad2b42b5a95a4d9.tar.gz
sci-856d88d5b61462241a36dcd90ad2b42b5a95a4d9.tar.bz2
sci-856d88d5b61462241a36dcd90ad2b42b5a95a4d9.zip
sci-libs/ensmallen: version bump to 2.15.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-libs/ensmallen')
-rw-r--r--sci-libs/ensmallen/Manifest1
-rw-r--r--sci-libs/ensmallen/ensmallen-2.15.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/ensmallen/Manifest b/sci-libs/ensmallen/Manifest
index 9da369098..8eb3ca75e 100644
--- a/sci-libs/ensmallen/Manifest
+++ b/sci-libs/ensmallen/Manifest
@@ -1,2 +1,3 @@
DIST ensmallen-2.14.2.tar.gz 1262697 BLAKE2B c3ecd10271a476cdb03de0a74dd1e7d250273481b540d9cadb44ff7292cdb1f4abbefaf7c1a90bd33c68928f766db8afafd45f253735a36de9def6ab222597bb SHA512 9f29d70f66748d6131b44fc2a580e9fc07131a3aeecaa9f6113fd635eaff8b52db90e487a389393a1976dcccb8c1f5850ea50e03308af90b58ba1c12fde2bd21
DIST ensmallen-2.15.0.tar.gz 1266409 BLAKE2B 379ea897d3b29440e89d65cb60c65dca3c34a530dd8a4cee321349d177455b020d4aa19ee1e701b46a325a8f56028c236ab80b0383bee84018952034106f7161 SHA512 7e8ea0d64788287e58ee14e922c81c18e1804a23dba3d144fe6e66de8a81dfd3755c9f36a1e8a480aa6e15f0f7b1ff886e0aeecde0be35993db0ba69ca7e12e0
+DIST ensmallen-2.15.1.tar.gz 1266496 BLAKE2B 7ff803207c59be03fa47e7fddafb49176d307fbea89f5688bd591898fb36d7d8ee018dec933b59a06063dc6c2a7117d3ec0d330cd37d475e4f387528f2d86f6a SHA512 4f0cda1ad0d02e823042fb6af03635677e3d5cac28f7f13fab20fc7f4b3d7fbe1b182777c573187a403eff5e5fd7e1e577e290a4b624a9c2a71cbfd347e14afa
diff --git a/sci-libs/ensmallen/ensmallen-2.15.1.ebuild b/sci-libs/ensmallen/ensmallen-2.15.1.ebuild
new file mode 100644
index 000000000..bb93e8246
--- /dev/null
+++ b/sci-libs/ensmallen/ensmallen-2.15.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="header only C++ library for numerical optimization"
+HOMEPAGE="https://ensmallen.org"
+SRC_URI="https://github.com/mlpack/ensmallen/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-libs/armadillo[lapack]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENMP=$(usex openmp)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}