aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-10-10 00:04:35 +0100
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2009-10-10 00:04:35 +0100
commit499fc483d3d6caf882a1c447f025c9159679fe70 (patch)
tree75df38e2866feb94c35b9a8377c7988981d03bd2 /sci-libs/lwpr
parentccpn now includes updates from upstream which are not provided in the releases (diff)
downloadsci-499fc483d3d6caf882a1c447f025c9159679fe70.tar.gz
sci-499fc483d3d6caf882a1c447f025c9159679fe70.tar.bz2
sci-499fc483d3d6caf882a1c447f025c9159679fe70.zip
Import of lwpr
Diffstat (limited to 'sci-libs/lwpr')
-rw-r--r--sci-libs/lwpr/ChangeLog11
-rw-r--r--sci-libs/lwpr/Manifest5
-rw-r--r--sci-libs/lwpr/files/lwpr-1.2.2-setup.py.patch12
-rw-r--r--sci-libs/lwpr/lwpr-1.2.2.ebuild75
-rw-r--r--sci-libs/lwpr/metadata.xml17
5 files changed, 120 insertions, 0 deletions
diff --git a/sci-libs/lwpr/ChangeLog b/sci-libs/lwpr/ChangeLog
new file mode 100644
index 000000000..482884f03
--- /dev/null
+++ b/sci-libs/lwpr/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/lwpr
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*lwpr-1.2.2 (09 Oct 2009)
+
+ 09 Oct 2009; SĂ©bastien Fabbro <bicatali@gentoo.org> +lwpr-1.2.2.ebuild,
+ +files/lwpr-1.2.2-setup.py.patch, +metadata.xml:
+ Initial import, ebuild based on bug #288032, initially submitted by
+ Florent Teichteil
+
diff --git a/sci-libs/lwpr/Manifest b/sci-libs/lwpr/Manifest
new file mode 100644
index 000000000..78c168892
--- /dev/null
+++ b/sci-libs/lwpr/Manifest
@@ -0,0 +1,5 @@
+AUX lwpr-1.2.2-setup.py.patch 517 RMD160 8c7e6bd38cff80d779b04d6147943bb960ba8c90 SHA1 591763838ec6359704e2d7ef18fb99131c345b48 SHA256 5b77f2f9a17b7759948c04c903ea12ada65cc3904f87d7ca0015edeb8d3260c2
+DIST lwpr-1.2.2.tar.gz 723920 RMD160 055f6c437e7e310b6f2ae77946443ee280c1334d SHA1 9e60bae960831f669701e106c276a3a4bea81b27 SHA256 a55d0ca8b66d4b62d07767ade714f545cf24d933b37d58613d8a79882afcf918
+EBUILD lwpr-1.2.2.ebuild 1687 RMD160 b9477ab966c593446092e578bf59cc9d3db5339b SHA1 f01e738c82f3247626195be1d88367012ec69cc3 SHA256 810a58edbc2e3cfbd11cd01e414938e7c5ba1add5632d1a103a24be6a0973a01
+MISC ChangeLog 358 RMD160 4b5b12ed86ac9fad77040e4e52424906b9b31cae SHA1 a1f62fb9c48ae2987272671fa4c9a82efc897d74 SHA256 7e122a6a311f4569158be0b1f3a93e038e80174208e4cc85f134005694c03d33
+MISC metadata.xml 731 RMD160 6398d7c8274b3b5086055ec1d934c88a73419127 SHA1 b1d63222eceb214ca91c49547ee3b59c6feadf15 SHA256 9c6fbc1c2093d759fd0d0564d6d037249f7902ba7451a1278099e05f43889596
diff --git a/sci-libs/lwpr/files/lwpr-1.2.2-setup.py.patch b/sci-libs/lwpr/files/lwpr-1.2.2-setup.py.patch
new file mode 100644
index 000000000..d560d164f
--- /dev/null
+++ b/sci-libs/lwpr/files/lwpr-1.2.2-setup.py.patch
@@ -0,0 +1,12 @@
+--- python/setup.py.orig 2009-10-09 21:53:17.000000000 +0100
++++ python/setup.py 2009-10-09 21:53:54.000000000 +0100
+@@ -5,7 +5,8 @@
+ module = Extension('lwpr',
+ include_dirs = ['../include',
+ os.path.join(get_python_lib(),'numpy','core','include')],
+- libraries = ['lwpr'],
++ libraries = ['lwpr'],
++ library_dirs=['../src/.libs'],
+ sources = ['lwprmodule.c'])
+
+ setup (name = 'LWPR Module',
diff --git a/sci-libs/lwpr/lwpr-1.2.2.ebuild b/sci-libs/lwpr/lwpr-1.2.2.ebuild
new file mode 100644
index 000000000..12686852c
--- /dev/null
+++ b/sci-libs/lwpr/lwpr-1.2.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils distutils
+
+DESCRIPTION="The Locally Weighted Projection Regression Library"
+HOMEPAGE="http://www.ipab.inf.ed.ac.uk/slmc/software/lwpr/"
+SRC_URI="http://www.ipab.inf.ed.ac.uk/slmc/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples octave python"
+
+RDEPEND="octave? ( >=sci-mathematics/octave-3 )
+ python? ( dev-python/numpy )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-setup.py.patch
+}
+
+src_configure() {
+ econf $(use_with octave octave "$(octave-config -p PREFIX)")
+ # threads buggy
+ # $(use_enable threads threads X) \
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+ if use python; then
+ cd python
+ distutils_src_compile
+ fi
+}
+
+src_test() {
+ emake check || die "emake test failed"
+ if use python; then
+ cd python
+ LD_LIBRARY_PATH=../src/.libs \
+ PYTHONPATH=$(dir -d build/lib*) \
+ "${python}" test.py || die "python test failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ mexflags="-DMATLAB -I../include -L./.libs -llwproctave" \
+ install || die "emake install failed"
+ dodoc README.TXT
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/lwpr_doc.pdf
+ dohtml html/* || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example_c/cross.c example_cpp/cross.cc || die
+ fi
+ if use octave; then
+ insinto /usr/share/octave/packages/${P}
+ doins matlab/*.m || die
+ fi
+ if use python; then
+ cd python
+ distutils_src_install
+ fi
+}
diff --git a/sci-libs/lwpr/metadata.xml b/sci-libs/lwpr/metadata.xml
new file mode 100644
index 000000000..dbae229f0
--- /dev/null
+++ b/sci-libs/lwpr/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription>
+ Locally Weighted Projection Regression (LWPR) is a recent algorithm
+ that achieves nonlinear function approximation in high dimensional spaces
+ with redundant and irrelevant input dimensions. At its core, it uses
+ locally linear models, spanned by a small number of univariate regressions in
+ selected directions in input space. A locally weighted variant of
+ Partial Least Squares (PLS) is employed for doing the dimensionality
+ reduction.
+</longdescription>
+<use>
+ <flag name='octave'>Add <pkg>sci-mathematics/octave</pkg> support</flag>
+</use>
+</pkgmetadata>