aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 12:55:41 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-30 12:55:41 +0100
commitbc1cab476261e0ffaea7a04cb7347266af8a0cfc (patch)
tree2c1c827d88082e24d12198656531bd143bcaa881 /sci-libs/optpp
parentsci-libs/pfft: version bump, EAPI bump (diff)
downloadsci-bc1cab476261e0ffaea7a04cb7347266af8a0cfc.tar.gz
sci-bc1cab476261e0ffaea7a04cb7347266af8a0cfc.tar.bz2
sci-bc1cab476261e0ffaea7a04cb7347266af8a0cfc.zip
sci-libs/optpp: EAPI bump, fix file collision
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'sci-libs/optpp')
-rw-r--r--sci-libs/optpp/optpp-2.4.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/sci-libs/optpp/optpp-2.4.ebuild b/sci-libs/optpp/optpp-2.4.ebuild
index c384880ef..054be4c11 100644
--- a/sci-libs/optpp/optpp-2.4.ebuild
+++ b/sci-libs/optpp/optpp-2.4.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools-utils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="C++ library for non-linear optimization"
HOMEPAGE="https://software.sandia.gov/opt++/"
-SRC_URI="${HOMEPAGE}/downloads/${P}.tar.gz"
+SRC_URI="https://software.sandia.gov/opt++/downloads/${P}.tar.gz"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
@@ -16,19 +16,21 @@ IUSE="doc mpi static-libs"
RDEPEND="
virtual/blas
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/lapack
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_configure() {
- local myeconfargs=(
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ econf \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
$(use_enable mpi)
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
- use doc && dohtml -r docs/*
+ default
+ # avoid file collision with sci-libs/lapack
+ rm "${ED}/usr/include/cblas.h"
+ use doc && dodoc -r docs/*
}