aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-01-22 09:39:15 -0500
committerHorea Christian <chr@chymera.eu>2024-01-22 09:39:15 -0500
commit1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c (patch)
tree0f71c6fb37e8b05c76e525f896aff03e23c98eaa /sci-libs
parentmedia-gfx/brlcad: updated doxygen dependency category (diff)
downloadsci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.tar.gz
sci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.tar.bz2
sci-1d9d9f6cbf7e933c4fed1f4ec4e3183b1ea0f76c.zip
sci-libs/nipype: add 1.8.6, drop 1.5.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nipype/Manifest2
-rw-r--r--sci-libs/nipype/nipype-1.8.6.ebuild (renamed from sci-libs/nipype/nipype-1.5.0.ebuild)25
2 files changed, 13 insertions, 14 deletions
diff --git a/sci-libs/nipype/Manifest b/sci-libs/nipype/Manifest
index a2ffd1d7a..6c9059e1c 100644
--- a/sci-libs/nipype/Manifest
+++ b/sci-libs/nipype/Manifest
@@ -1,2 +1,2 @@
-DIST nipype-1.5.0.tar.gz 2735317 BLAKE2B d618714b15defde52325bac32a80449846b448d1c141a21f9d950976c8c89624d714dbab10b4cd99fe20d4eb99ceb4095ebc6ddc567f57b3803e2c16ffda155a SHA512 eb11096a090855278c3e76ffe9643ab4de046a017511ba51f59448fd8cf9d67a4f6c552acbbbdd38065cfb456c24fd21299cf698fa05c5be507524622f28ac85
DIST nipype-1.8.4.tar.gz 2914433 BLAKE2B c25b82c22641f6df2b57c8a07fd318034bb4fe4eaa1037baebc1ffc03d3e1add347d9f0c94139144fc17043a5c97926c88b40755f19794cc71366d76ba339698 SHA512 8949226accd7c158b6a3ec92389a11760a9b306098ccb8ef50844efbddb4e6a9108bb6a32ec7b0402c4ea56881a3548b052fe7f5e757d2771aea5b2eebc9377b
+DIST nipype-1.8.6.tar.gz 2921102 BLAKE2B 79a2131b8265f1b0a3a8d2fa6ff56cbbc2d393c79099178cf036d82357a971a72f024b132d7b4d7d4af85165f562192b6cc5cfc9e797105bdc009734e8a89033 SHA512 23140beb02f4c3807d9d0291bde41ce8c1b06e48dc94001b007f193caaa89428387d1528fa20ae328d2c4a781024c9acf07f7be9ce507ecb2f1daf338c092eec
diff --git a/sci-libs/nipype/nipype-1.5.0.ebuild b/sci-libs/nipype/nipype-1.8.6.ebuild
index 750c3ba05..88bc23395 100644
--- a/sci-libs/nipype/nipype-1.5.0.ebuild
+++ b/sci-libs/nipype/nipype-1.8.6.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+),sqlite"
@@ -16,7 +17,9 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RESTRICT="!test? ( test )"
+# Tests fail with numpy import error:
+# https://github.com/nipy/nipype/issues/3626
+RESTRICT="test"
DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
@@ -28,30 +31,28 @@ DEPEND="
${RDEPEND}
)
"
-# Dependency disabled as upstream test configuration which requires it fails
-#dev-python/pytest-xdist[${PYTHON_USEDEP}]
RDEPEND="
- >=dev-python/click-6.6[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/looseversion[${PYTHON_USEDEP}]
dev-python/networkx[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pydot[${PYTHON_USEDEP}]
- dev-python/pydotplus[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/rdflib-5.0.0[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/traits[${PYTHON_USEDEP}]
+ <dev-python/traits-6.4.0[${PYTHON_USEDEP}]
"
PATCHES=(
- "${FILESDIR}/${P}"-version_check.patch
- "${FILESDIR}/${P}"-collections.patch
+ "${FILESDIR}/${PN}-1.8.4-no_etelemetry.patch"
)
src_prepare() {
# Remove etelemetry
+ # Doing this separately since the file is affected by another patch.
sed -i '/"etelemetry/d' nipype/info.py requirements.txt || die
# Mark failing tests
@@ -69,12 +70,10 @@ python_install_all() {
doenvd "${FILESDIR}/98nipype"
}
+# Reported upstream:
+# https://github.com/nipy/nipype/issues/3540
EPYTEST_DESELECT=(
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_compcor_variance_threshold_and_metadata
- nipype/algorithms/tests/test_CompCor.py::TestCompCor::test_tcompcor
nipype/interfaces/tests/test_io.py::test_s3datagrabber_communication
- nipype/utils/tests/test_cmd.py::TestNipypeCMD::test_main_returns_0_on_help
)
python_test() {