summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-05 17:54:19 +0800
committerPatrick Lauer <patrick@gentoo.org>2013-03-05 17:54:19 +0800
commit43caf0ace7806b1d32105f674f59bb84c4a1acf0 (patch)
treef50d2dde40d114f7826d80fd3a416b7c6b9e9645 /games-board/qbriscola/qbriscola-1.1-r1.ebuild
parentdev-util/serial-io: Fix qt deps, EAPI bump, add ~amd64 keyword (diff)
downloadsunrise-reviewed-43caf0ace7806b1d32105f674f59bb84c4a1acf0.tar.gz
sunrise-reviewed-43caf0ace7806b1d32105f674f59bb84c4a1acf0.tar.bz2
sunrise-reviewed-43caf0ace7806b1d32105f674f59bb84c4a1acf0.zip
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
Diffstat (limited to 'games-board/qbriscola/qbriscola-1.1-r1.ebuild')
-rw-r--r--games-board/qbriscola/qbriscola-1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-board/qbriscola/qbriscola-1.1-r1.ebuild b/games-board/qbriscola/qbriscola-1.1-r1.ebuild
new file mode 100644
index 000000000..78c9c2c7b
--- /dev/null
+++ b/games-board/qbriscola/qbriscola-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit games cmake-utils
+
+DESCRIPTION="Italian card game called briscola"
+HOMEPAGE="http://qbriscola.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtsql:4[sqlite]
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="README"
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}