summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-0.6.1.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.6.1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.6.1.ebuild
new file mode 100644
index 000000000..bf050edcf
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PYTHON_DEPEND='*:2.6'
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='2.4 2.5'
+inherit distutils python
+
+DESCRIPTION="Update live packages and emerge the modified ones"
+HOMEPAGE="http://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="http://github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_install() {
+ distutils_src_install
+
+ dodoc README sets.conf.example || die
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,} || die
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf || die
+}