summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-17 05:55:10 -0500
committerMike Frysinger <vapier@gentoo.org>2015-02-17 06:00:55 -0500
commit3cfb8b8532f86d3e3e47c02dcb32cf4fb4072480 (patch)
tree58e4af7f30d2deec967d1c23d7e15e54a14f28be /scripts
parentbinutils: move old versions from main gentoo tree (diff)
downloadtoolchain-3cfb8b8532f86d3e3e47c02dcb32cf4fb4072480.tar.gz
toolchain-3cfb8b8532f86d3e3e47c02dcb32cf4fb4072480.tar.bz2
toolchain-3cfb8b8532f86d3e3e47c02dcb32cf4fb4072480.zip
gdb: update snapshots
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/update-gdb4
1 files changed, 2 insertions, 2 deletions
diff --git a/scripts/update-gdb b/scripts/update-gdb
index 8ade88a..a6d64c2 100755
--- a/scripts/update-gdb
+++ b/scripts/update-gdb
@@ -29,8 +29,8 @@ sed -i 's/\r$//' ${l}
# First unload ones that no longer exist.
ebuilds=$(echo ${PN}-?.?.50.*.ebuild)
for e in ${ebuilds} ; do
- f=$(echo "${e}" | sed -e 's:^gdb-:gdb-weekly-:g' -e 's:.ebuild:.tar.bz2:g')
- if grep -q "\<${f}$" ${l} ; then
+ f=$(echo "${e}" | sed -e 's:^gdb-:gdb-weekly-:g' -e 's:.ebuild:.tar.(bz2|xz):g')
+ if grep -qE "\<${f}$" ${l} ; then
continue
fi
git rm -f ${e}