summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.2.0_alpha20090325.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20090325.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20090325.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20090325.ebuild
new file mode 100644
index 0000000..6aa6b7c
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20090325.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCC_FILESDIR="${PORTDIR}/sys-devel/gcc/files"
+
+inherit toolchain
+
+KEYWORDS=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=${CATEGORY}/binutils-2.16.1"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use vanilla && return 0
+
+ # Fix cross-compiling
+ epatch "${GCC_FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}