summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.3-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.3-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-4.7.3-r1.ebuild b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
index 6940067..8e77575 100644
--- a/sys-devel/gcc/gcc-4.7.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.7.3-r1.ebuild
@@ -23,11 +23,12 @@ src_prepare() {
if has_version '<sys-libs/glibc-2.12' ; then
ewarn "Your host glibc is too old; disabling automatic fortify."
ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
- EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+
+ rm "${WORKDIR}"/patch/10_all_default-fortify-source.patch || die
fi
# drop the x32 stuff in the next patchset #543578
- EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+ rm "${WORKDIR}"/patch/90_all_gcc-4.7-x32.patch || die
toolchain-legacy_src_prepare
}