aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Harvey <chris@basementcode.com>2010-06-11 21:57:14 -0400
committerChristopher Harvey <chris@basementcode.com>2010-06-11 21:57:14 -0400
commit923502f0e863d5902e52d20fa302481427ca77e1 (patch)
treea466eda54667db5e7c1a686b9c8e51ab8e95748c
parentMerged frontend and backend into 'ventoo' (diff)
downloadventoo-923502f0e863d5902e52d20fa302481427ca77e1.tar.gz
ventoo-923502f0e863d5902e52d20fa302481427ca77e1.tar.bz2
ventoo-923502f0e863d5902e52d20fa302481427ca77e1.zip
Added ventoo executable, for /usr/bin
-rw-r--r--setup.py3
-rwxr-xr-xventoo34
2 files changed, 37 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 1d665e6..78f04aa 100644
--- a/setup.py
+++ b/setup.py
@@ -12,6 +12,9 @@ for dirpath, dirnames, filenames in os.walk('modules'):
if dirname.startswith('.'): del dirnames[i]
built_data_files.append([os.path.join('/usr/share/ventoo/', dirpath), [os.path.join(dirpath, f) for f in filenames]])
+#install the executable
+built_data_files.append(['/usr/bin', ['ventoo']])
+
#update module search paths for install location
f = open("src/ventoo/search_paths.py", 'a')
f.write("\nmodules = ['/usr/share/ventoo/modules']\n")
diff --git a/ventoo b/ventoo
new file mode 100755
index 0000000..d7d9779
--- /dev/null
+++ b/ventoo
@@ -0,0 +1,34 @@
+#!/usr/bin/env python
+
+import sys
+import os.path as osp
+import ventoo.main
+import augeas
+import shutils
+import os
+
+sandboxDir = '/'
+
+if len(sys.argv) > 1:
+ sandboxDir = sys.argv[1]
+if not osp.isdir(sandboxDir):
+ print sandboxDir + " is not a directory."
+ sys.exit(0)
+
+print 'Starting augeas...'
+ #None could be a 'loadpath'
+a = augeas.Augeas(sandboxDir, None, augeas.Augeas.SAVE_NEWFILE)
+print 'Creating window...'
+
+if sandboxDir == '/':
+ pass
+#Note, it IS possible to create mutiple windows and augeas
+#instances to edit multiple "roots" at the same time.
+window = ventoo.main.MainWindow(a)
+window.show_all()
+window.hideApplyDiffButton() #TODO: overload show_all to preserve apply button state.
+
+#clear the diff storage place...
+shutil.rmtree(ventoo.augeas_utils.getDiffRoot(), True)
+os.makedirs(ventoo.augeas_utils.getDiffRoot())
+gtk.main()