summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Schwyn <gentoo@bitcetera.com>2008-12-13 17:34:59 +0000
committerSven Schwyn <gentoo@bitcetera.com>2008-12-13 17:34:59 +0000
commit58a20c8ff091273c05413b342ffbbaaf2b686571 (patch)
treecd50b3bddb910d05f24d74a5083f30e7cd32fb3a /media-libs
parentnet-misc/dahdi: update the Manifest (diff)
downloadvoip-58a20c8ff091273c05413b342ffbbaaf2b686571.tar.gz
voip-58a20c8ff091273c05413b342ffbbaaf2b686571.tar.bz2
voip-58a20c8ff091273c05413b342ffbbaaf2b686571.zip
media-libs/spandsp: version bump
svn path=/trunk/; revision=742
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/spandsp/ChangeLog6
-rw-r--r--media-libs/spandsp/Manifest2
-rw-r--r--media-libs/spandsp/spandsp-0.0.6_pre3.ebuild47
3 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/spandsp/ChangeLog b/media-libs/spandsp/ChangeLog
index 90bd06f..f22ed57 100644
--- a/media-libs/spandsp/ChangeLog
+++ b/media-libs/spandsp/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-libs/spandsp
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2006/02/22 02:08:04 hd_brummy Exp $
+ 13 Dec 2008; Sven Schwyn (svoop) <gentoo@bitcetera.com>
+ +spandsp-0.0.6_pre3.ebuild:
+ version bump
+
17 Oct 2006; Piotr Jaroszyński <peper@aster.pl>
-spandsp-0.0.2_pre20.ebuild, -spandsp-0.0.2_pre21.ebuild,
-spandsp-0.0.2_pre23.ebuild, -spandsp-0.0.2_pre25.ebuild,
diff --git a/media-libs/spandsp/Manifest b/media-libs/spandsp/Manifest
index 48312a4..62296d3 100644
--- a/media-libs/spandsp/Manifest
+++ b/media-libs/spandsp/Manifest
@@ -1,3 +1,5 @@
DIST spandsp-0.0.3pre24.tgz 1575682 RMD160 c4d707b76da2961f19e98e3dda33bfc46cd7b7e8 SHA1 b56e11656360c4dd6a3048fcd785c2e51ea76afc SHA256 5f808cd038217b339e5bb926c1e17e762bd0e6d367d1e53e4f5bdae36cb3a6f3
+DIST spandsp-0.0.6pre3.tgz 2462372 RMD160 395884e5fb9abc7f9d70b12308540b65bc064cf8 SHA1 227d2641839ec94ea61eae2cb7bcfddaa78bfc9f SHA256 f5691bcb250dde680075fcbe4c47e729894295a6868c70cdd7d20bd8932904ee
EBUILD spandsp-0.0.3_pre24.ebuild 814 RMD160 ed9e2ad97d12da05f8212d6f8fec89d258b7955e SHA1 b90e4aa18327a0f4f4a35cd769037dc9f971df0f SHA256 047f8d7fd133a4edf916797e926779fe15851b1f37b82fb17c440feb2c1799f9
+EBUILD spandsp-0.0.6_pre3.ebuild 1142 RMD160 e788db502ed8c98d2867c6344d82895726809697 SHA1 01e3a75222594031524c28b938525b92f3cfd915 SHA256 ce7ec92721ee2ce757628d29882fdd600c562ed933e53c9d3ddd72310a5402d8
MISC ChangeLog 618 RMD160 8a28dca62fe34827e82a06a87bc0c6d16d440b9d SHA1 6820f47feb813252b8b9702d1a120f74269f98e7 SHA256 a7577c5afee315a7e84170b6fc42e8becd14d297e572db8beb309b08966aa6f3
diff --git a/media-libs/spandsp/spandsp-0.0.6_pre3.ebuild b/media-libs/spandsp/spandsp-0.0.6_pre3.ebuild
new file mode 100644
index 0000000..c6ba32e
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6_pre3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator
+
+DESCRIPTION="Library of DSP functions for telephony."
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc mmx sse"
+# test"
+
+RDEPEND="media-libs/audiofile
+ media-libs/tiff
+ =sci-libs/fftw-3*"
+# test? ( x11-libs/libXft
+# x11-libs/libXext
+# x11-libs/libX11
+# dev-libs/libxml2
+# x11-libs/fltk )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_compile() {
+ ewarn "MMX and SSE are broken and should be disabled on amd64 for this version."
+ epause 5
+ econf --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable mmx) \
+ $(use_enable sse)
+# $(use_enable test tests) \
+# $(use_enable test test-data)
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS NEWS README
+ use doc && dohtml -r doc/{api/html/*,t38_manual}
+}