summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ortp/ortp-0.15.0.ebuild')
-rw-r--r--net-libs/ortp/ortp-0.15.0.ebuild48
1 files changed, 35 insertions, 13 deletions
diff --git a/net-libs/ortp/ortp-0.15.0.ebuild b/net-libs/ortp/ortp-0.15.0.ebuild
index 177f121..66c07d9 100644
--- a/net-libs/ortp/ortp-0.15.0.ebuild
+++ b/net-libs/ortp/ortp-0.15.0.ebuild
@@ -2,9 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# TODO: with +srtp, ortp throws a QA notice about TEXTREL
-# TODO: srtp USE flag should be masked on unKEYWORDED archs
-
EAPI="2"
DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
@@ -14,15 +11,21 @@ SRC_URI="http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc ipv6 minimal srtp"
+IUSE="debug doc examples ipv6 minimal srtp ssl"
-RDEPEND="dev-libs/openssl
- srtp? ( net-libs/libsrtp )"
+RDEPEND="srtp? ( net-libs/libsrtp )
+ ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+# TODO: sandbox violation with +doc
+# TODO: test USE="srtp -ssl"
+
+# TODO: with +srtp, ortp throws a QA notice about TEXTREL
+# TODO: srtp USE flag should be masked on unKEYWORDED archs
+
src_prepare() {
- # to be sure doc is not compiled nor installed with -doc and doxygen inst
+ # to be sure doc is not builded nor installed w/ -doc and doxygen installed
if ! use doc; then
sed -i -e 's/test $DOXYGEN != //' configure \
|| die "patching configure failed"
@@ -34,6 +37,17 @@ src_prepare() {
|| die "patching configure failed"
fi
+ # to authorize -ssl even with openssl installed
+ if ! use ssl; then
+ sed -i -e 's/SSL_LIBS=".*"/SSL_LIBS=""/' \
+ -e 's/openssl\/.*.h/poll.h/' configure \
+ || die "patching configure failed"
+ fi
+
+ # do not build examples programs, see bug 226247
+ sed -i -e 's/SUBDIRS = . tests/SUBDIRS = ./' src/Makefile.in \
+ || die "patching src/Makefile.in failed"
+
# new Makefile.in add /${P} to docdir
if use doc; then
sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
@@ -46,17 +60,25 @@ src_configure() {
# mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
# strict adds -Werror, don't want it
econf \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_enable minimal perf) \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --enable-libtool-lock \
--disable-memcheck \
--disable-mode64bit \
--disable-strict \
- --with-pic \
- --docdir=/usr/share/doc/${PF}
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable minimal perf)
}
src_install() {
- einstall || die "einstall failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c || die "doins failed"
+ fi
}