summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-02-21 22:11:48 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-02-21 22:11:48 +0000
commitd3ea96e12549b4f75e314418de97a6820a07466f (patch)
treec6443803a46269a49cc0bf92cc6d61b6288f6fe6 /setup.py
downloadwebapp-config-d3ea96e12549b4f75e314418de97a6820a07466f.tar.gz
webapp-config-d3ea96e12549b4f75e314418de97a6820a07466f.tar.bz2
webapp-config-d3ea96e12549b4f75e314418de97a6820a07466f.zip
Added current version
svn path=/trunk/webapp-config/; revision=2
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..65ab502
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+
+import sys
+
+from distutils.core import setup
+
+# this affects the names of all the directories we do stuff with
+sys.path.insert(0, './')
+from WebappConfig.version import WCVERSION
+
+
+setup(name = 'webapp-config',
+ version = WCVERSION,
+ description = 'Python script for managing the deployment of web-based applications',
+ author = 'Stuart Herbert, Renat Lumpau, Gunnar Wrobel',
+ author_email = 'stuart@gentoo.org',
+ url = 'http://svn.gnqs.org/projects/vhost-tools',
+ packages = ['WebappConfig'],
+ scripts = ['sbin/webapp-config', 'sbin/webapp-cleaner'],
+ license = 'GPL',
+ )