summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-02-23 07:24:15 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-02-23 07:24:15 +0000
commit0466748f5ef6b17074bbbbfc716f60eb733d1138 (patch)
tree3ec0ce53726a4a9cb69c2fc85274515678b65086 /dev-php
parentAdded PEAR-Config (diff)
downloadwebapps-experimental-0466748f5ef6b17074bbbbfc716f60eb733d1138.tar.gz
webapps-experimental-0466748f5ef6b17074bbbbfc716f60eb733d1138.tar.bz2
webapps-experimental-0466748f5ef6b17074bbbbfc716f60eb733d1138.zip
Added phpmailer library
svn path=/experimental/; revision=147
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpmailer/Manifest2
-rw-r--r--dev-php/phpmailer/files/digest-phpmailer-1.731
-rw-r--r--dev-php/phpmailer/phpmailer-1.73.ebuild35
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/phpmailer/Manifest b/dev-php/phpmailer/Manifest
new file mode 100644
index 0000000..6e5f14d
--- /dev/null
+++ b/dev-php/phpmailer/Manifest
@@ -0,0 +1,2 @@
+MD5 2565c59f53f038372c5f22e990178416 files/digest-phpmailer-1.73 65
+MD5 c13a4856592b5d4a88f6c60144c6428c phpmailer-1.73.ebuild 750
diff --git a/dev-php/phpmailer/files/digest-phpmailer-1.73 b/dev-php/phpmailer/files/digest-phpmailer-1.73
new file mode 100644
index 0000000..e437aa6
--- /dev/null
+++ b/dev-php/phpmailer/files/digest-phpmailer-1.73
@@ -0,0 +1 @@
+MD5 3a6ce5ff38090d6ca4881e31da00f623 phpmailer-1.73.tar.gz 68644
diff --git a/dev-php/phpmailer/phpmailer-1.73.ebuild b/dev-php/phpmailer/phpmailer-1.73.ebuild
new file mode 100644
index 0000000..90591ec
--- /dev/null
+++ b/dev-php/phpmailer/phpmailer-1.73.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit php-lib-r1
+
+DESCRIPTION="PHP email transport class featuring multiple file attachments, SMTP servers, CCs, BCCs, HTML messages, and word wrap, and more."
+HOMEPAGE="http://phpmailer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/phpmailer/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="${DEPEND}"
+RDEPEND="${RDEPEND}"
+
+need_php_by_category
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+
+ cd language
+ LANGUAGES=$(ls *.php)
+ cd ..
+
+ # install php files
+ php-lib-r1_src_install . *.php
+ php-lib-r1_src_install language ${LANGUAGES}
+
+ # install documentation
+ dodoc-php docs phpdoc README ChangeLog.txt
+}