summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xen-4.16-efi.patch')
-rw-r--r--xen-4.16-efi.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/xen-4.16-efi.patch b/xen-4.16-efi.patch
new file mode 100644
index 0000000..0de5575
--- /dev/null
+++ b/xen-4.16-efi.patch
@@ -0,0 +1,12 @@
+diff -urN a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile
+--- a/xen/arch/x86/Makefile 2021-11-30 06:42:42.000000000 -0500
++++ b/xen/arch/x86/Makefile 2022-02-17 07:43:06.597244620 -0500
+@@ -127,7 +127,7 @@
+ CFLAGS-$(XEN_BUILD_EFI) += -DXEN_BUILD_EFI
+
+ # Check if the linker supports PE.
+-EFI_LDFLAGS = $(patsubst -m%,-mi386pep,$(XEN_LDFLAGS)) --subsystem=10
++EFI_LDFLAGS = -mi386pep $(patsubst -m%,-mi386pep,$(XEN_LDFLAGS)) --subsystem=10
+ XEN_BUILD_PE := $(if $(XEN_BUILD_EFI),$(call ld-option,$(EFI_LDFLAGS) --image-base=0x100000000 -o efi/check.efi efi/check.o))
+ # If the above failed, it may be merely because of the linker not dealing well
+ # with debug info. Try again with stripping it.