summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-04-13 13:06:38 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-04-13 13:06:38 +0000
commit206de5e7b2e3d39055341347f96d0f1f2cdcc577 (patch)
tree429951a405ac430557789eacf7e6b5a485ee370c /www-apps
parentwww-apps/drupal: Add 8.7.13, 8.8.5 and 8.9.0_beta2 releases. (diff)
downloadjmbsvicetto-206de5e7b2e3d39055341347f96d0f1f2cdcc577.tar.gz
jmbsvicetto-206de5e7b2e3d39055341347f96d0f1f2cdcc577.tar.bz2
jmbsvicetto-206de5e7b2e3d39055341347f96d0f1f2cdcc577.zip
www-apps/drupal: Add initial drupal 9 beta release.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-9.0.0_beta2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 19f912f..40d6e71 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -4,3 +4,4 @@ DIST drupal-8.7.13.tar.gz 17930132 BLAKE2B 926614cfa214a4c6bceea89d730f888fadd63
DIST drupal-8.8.4.tar.gz 19488274 BLAKE2B 47cd41ec3d494f5dc948d70c45072fa8040698db133141947348b201e9853c04b91460b1c064d36e45dd20d0ce99c2a1a592e4f2a0f99348cdfd08fb97b9f0e1 SHA512 e85e1262eff6274ada1d2625fbd7744b22611807e55252fcaeae722dae5dbc1c552841681f80d552e2d68f7ab2cdca8915e9a2e4c3dac9870fa92c0cb3910286
DIST drupal-8.8.5.tar.gz 19487785 BLAKE2B f7f64482c122009a7517bc299abee2a69f37b7732f4caa6348c811324c1875d38c3a8c71e031f451b1926e9e3b209c1da6db743451c28cf1e5a8c5ea2b13eee4 SHA512 15c1b574867066601d19f1cc45f3a65301f11e034f1aed4ab2b5566e5efc7b70ca7d12482fc94bd936b4b1b6bfab0fdc1eec1470d44a6de157eeb5bf8c178124
DIST drupal-8.9.0-beta2.tar.gz 19748832 BLAKE2B c9413a6eae4a5d2089ccaadf6337027e04637f0524f85f7b4630db8dfa818e8ffa563304838453ad6fe2109f2056c93e454f6b61eef5c888b6fd24eb715e3ccc SHA512 0d3d58c9221dd813167e65bb7d5491fdfa778baba18d06be80a1a15fa06157038134816ab85bcf930fa0b4da90081d31e9363f2a86897d8c0db8e980e1687fc7
+DIST drupal-9.0.0-beta2.tar.gz 16803313 BLAKE2B 351d1b448cbeb411bf4f810a609f03eb8e1c770b41d838a447b89d2a5b78cae9f68e22f2ed78b37431fa1cffdc66ac50baf96d6b6d3e46f07e719588d82d3f26 SHA512 718ba97157744884099b4c8cfcf2fb0a6ba0c2ceccd6e27f729bbba22aab35045d86b19de70db6b9441ec3580d7fe81b49335f50b4b8a7dd35b8abebe0779b20
diff --git a/www-apps/drupal/drupal-9.0.0_beta2.ebuild b/www-apps/drupal/drupal-9.0.0_beta2.ebuild
new file mode 100644
index 0000000..50acdd3
--- /dev/null
+++ b/www-apps/drupal/drupal-9.0.0_beta2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}