summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-02-19 17:08:36 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-02-19 17:08:36 -0600
commitb90da3a88a76079d91a7712af2c3b77922494b10 (patch)
treebaccb5e008e26cbd4ce45f1b07f36a578c9e02b2
parentsys-fs/btrfs-heatmap: update to modern python eclass (diff)
downloadtamiko-b90da3a88a76079d91a7712af2c3b77922494b10.tar.gz
tamiko-b90da3a88a76079d91a7712af2c3b77922494b10.tar.bz2
tamiko-b90da3a88a76079d91a7712af2c3b77922494b10.zip
media-gfx/displaycal: add displaycal
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.8.9.3.ebuild67
-rw-r--r--media-gfx/displaycal/metadata.xml11
3 files changed, 79 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
new file mode 100644
index 0000000..bc9eb1c
--- /dev/null
+++ b/media-gfx/displaycal/Manifest
@@ -0,0 +1 @@
+DIST DisplayCAL-3.8.9.3.tar.gz 10639277 SHA256 7c34dfbd9f66f24f1d4c88de4a5a0de688aad719f095874b6259637d30893bea SHA512 cece09605c12be6a154d8d8b088005e527a9e6674a89ec2787b0687a92b7f424749681f149a07bb798df6729c9f4c37e8760abeec115a014c06f94f25fc2f904 WHIRLPOOL 55ebd2ca92fc48283a58ab8ce14e48d155752f46fc75e5968cabc33214846bc6a6d029eeb446ccd9a555af6876ba83116ddf1f43e81c3c6db950cb9884b02811
diff --git a/media-gfx/displaycal/displaycal-3.8.9.3.ebuild b/media-gfx/displaycal/displaycal-3.8.9.3.ebuild
new file mode 100644
index 0000000..d70de6c
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.8.9.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-libs/libXinerama-1.1
+"
+RDEPEND="${DEPEND}
+ dev-python/faulthandler[${PYTHON_USEDEP}]
+ || (
+ dev-python/numpy-python2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+# Just in case someone renames the ebuild
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Do not generate udev/hotplug files
+ sed -e '/if os.path.isdir/s#/etc/udev/rules.d\|/etc/hotplug#\0-non-existant#' \
+ -i DisplayCAL/setup.py || die
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ sed -e '/if which/s#xdg-icon-resource#\0-non-existant#' \
+ -e '/if which/s#xdg-desktop-menu#\0-non-existant#' \
+ -i DisplayCAL/postinstall.py || die
+
+ # Remove deprecated Encoding key from .desktop file
+ sed -e '/Encoding=UTF-8/d' -i misc/*.desktop || die
+
+ # Remove x-world Media Type
+ sed -e 's/x\-world\/x\-vrml\;//g' \
+ -i misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}
diff --git a/media-gfx/displaycal/metadata.xml b/media-gfx/displaycal/metadata.xml
new file mode 100644
index 0000000..8e283c1
--- /dev/null
+++ b/media-gfx/displaycal/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">dispcalgui</remote-id>
+ </upstream>
+</pkgmetadata>