summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-03-16 11:07:37 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-03-16 11:08:46 -0500
commite9175c8fd6cc1ad5b2d989654bc1e72f38abaeac (patch)
treea4c867e986dd57e7686f84a3415102fbd4ee56fa
parentsci-libs/opencascade: version bump to 7.3.0 (diff)
downloadtamiko-e9175c8fd6cc1ad5b2d989654bc1e72f38abaeac.tar.gz
tamiko-e9175c8fd6cc1ad5b2d989654bc1e72f38abaeac.tar.bz2
tamiko-e9175c8fd6cc1ad5b2d989654bc1e72f38abaeac.zip
sci-libs/ginkgo: add live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/ginkgo/ginkgo-9999.ebuild45
-rw-r--r--sci-libs/ginkgo/metadata.xml22
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-libs/ginkgo/ginkgo-9999.ebuild b/sci-libs/ginkgo/ginkgo-9999.ebuild
new file mode 100644
index 0000000..ae37837
--- /dev/null
+++ b/sci-libs/ginkgo/ginkgo-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical linear algebra software package"
+HOMEPAGE="https://ginkgo-project.github.io/"
+
+inherit git-r3
+EGIT_REPO_URI="https://github.com/ginkgo-project/ginkgo"
+SRC_URI=""
+KEYWORDS=""
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+IUSE=""
+
+# TODO: add slepc use flag once slepc is packaged for gentoo-science
+REQUIRED_USE=""
+
+RDEPEND=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s#\"lib\"#\"$(get_libdir)\"#g" \
+ -e "s#\"lib/#\"$(get_libdir)/#g" \
+ cmake/install_helpers.cmake || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DGINKGO_DEVEL_TOOLS=OFF
+ -DGINKGO_BUILD_TESTS=OFF
+ -DGINKGO_BUILD_BENCHMARKS=OFF
+ -DGINKGO_BUILD_OMP=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/ginkgo/metadata.xml b/sci-libs/ginkgo/metadata.xml
new file mode 100644
index 0000000..e67b345
--- /dev/null
+++ b/sci-libs/ginkgo/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ginkgo is a high-performance linear algebra library for manycore
+ systems, with a focus on sparse solution of linear systems. It is
+ implemented using modern C++, with GPU kernels implemented in CUDA.
+ </longdescription>
+ <use>
+ </use>
+ <upstream>
+ <remote-id type="github">ginkgo-project/ginkgo</remote-id>
+ </upstream>
+</pkgmetadata>