summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-25 18:35:44 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-25 18:35:44 -0500
commitb9345874ac819e1f52e69b3014042446823b844b (patch)
tree5a2a7eb7e5a6eeb03b0509e00617d45da681781f /net-analyzer/flent/flent-1.3.2.ebuild
parentmedia-gfx/displaycal: add displaycal (diff)
downloadtamiko-b9345874ac819e1f52e69b3014042446823b844b.tar.gz
tamiko-b9345874ac819e1f52e69b3014042446823b844b.tar.bz2
tamiko-b9345874ac819e1f52e69b3014042446823b844b.zip
net-analyzer/flent: add package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'net-analyzer/flent/flent-1.3.2.ebuild')
-rw-r--r--net-analyzer/flent/flent-1.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/flent/flent-1.3.2.ebuild b/net-analyzer/flent/flent-1.3.2.ebuild
new file mode 100644
index 0000000..58e37af
--- /dev/null
+++ b/net-analyzer/flent/flent-1.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="The FLExible Network Tester"
+HOMEPAGE="https://flent.org/"
+SRC_URI="https://github.com/tohojo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+qt5 +plots"
+
+RDEPEND="qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+ plots? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ net-analyzer/netperf[demo]
+ net-misc/iperf
+ net-analyzer/fping"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"