summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-12-11 12:23:58 -0500
committerMatt Turner <mattst88@gentoo.org>2024-12-11 12:23:58 -0500
commit041639f9a38a9d4d3e8198778efa53725e582fc9 (patch)
tree9e853bf611def8fae2a01ddf8c753bfac55b6afb
parentmedia-libs/mesa: Version bump to 24.3.1 (diff)
downloadgentoo-041639f9a38a9d4d3e8198778efa53725e582fc9.tar.gz
gentoo-041639f9a38a9d4d3e8198778efa53725e582fc9.tar.bz2
gentoo-041639f9a38a9d4d3e8198778efa53725e582fc9.zip
media-libs/gmmlib: Version bump to 22.5.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/gmmlib-22.5.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index b04239406264..60218ea3b2a0 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1,3 +1,4 @@
DIST intel-gmmlib-22.5.2.tar.gz 867665 BLAKE2B 64559ec6489614df352ba58d25f8706c234f3cff008228a7056e29d92584fab27af311fdb3db8c2e4f6983598019c646df8761ed422a47bcdbff02e79896d613 SHA512 516e2cc0d678d8fd44d8d2b1bfdf61c05670c01c906bd7f55a807846cd6399d4b616f86e6a1d85e2a6a0480c4616a40e9d5b29a3f45fbf588cc4d725ada71d49
DIST intel-gmmlib-22.5.3.tar.gz 867696 BLAKE2B e7fe7394e0e4ee319a35a551908649e209c28f62fc566eab522f7182a78771b35a58ae067118f198eaca2d4f9cbbf58e4f54b9c838b87eed6ac82f2dce7158f1 SHA512 6649f241096b3b81a63c7d29b42494f5621dd9988f2570eaeb7164a4e5a71083180d4a8634782c4831ab8cd22e6b736a2e45e1a52cd5b70f62fe892411362444
DIST intel-gmmlib-22.5.4.tar.gz 868826 BLAKE2B 8a3d455a271d2e76e790e980e96ab0d9bd70854c039272b34eb605d8175749a9a561178ec022d197960bb4e9226217ed43c1a53f2598b1c6910931ca35d4c1c1 SHA512 08735c056a443f5f998b089e8a88bb61f1b0ceb2557971af3c9a0235aca3846888bd32ec42a9750e311d0575a84111c897a6417bcaf3ecf0eac60fa2549f5d93
+DIST intel-gmmlib-22.5.5.tar.gz 868894 BLAKE2B be17a0b1c16bf0ffcb37da3f63db20643803757ea42911f5666218e34bb3f59919bfa369749bef81598e8fb1855a8cad7347b6811791bc2c483b20a3e644e6dd SHA512 8603847f7d2daf0e7839973fea96fa552dbd8c25f29eb961a4f3c5918c70e61ed975a1f6f886547b605dd9f65a059e9decad6372a4269e2b61195259b049630e
diff --git a/media-libs/gmmlib/gmmlib-22.5.5.ebuild b/media-libs/gmmlib/gmmlib-22.5.5.ebuild
new file mode 100644
index 000000000000..2a09f24b8f3d
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.5.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == *9999 ]] ; then
+ : ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
+ if [[ ${PV%9999} != "" ]] ; then
+ : ${EGIT_BRANCH:="release/${PV%.9999}"}
+ fi
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
+fi
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}