summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-09-24 17:13:13 -0600
committerTim Harder <radhermit@gentoo.org>2019-09-24 17:13:13 -0600
commit0de5243505215ec110dceffe16d069b1cbc8691c (patch)
treef89683b9923c2ed92d0e2a72a0c962f57880ff73
parentdev-util/pkgcheck: version bump to 0.6.6 (diff)
downloadgentoo-0de5243505215ec110dceffe16d069b1cbc8691c.tar.gz
gentoo-0de5243505215ec110dceffe16d069b1cbc8691c.tar.bz2
gentoo-0de5243505215ec110dceffe16d069b1cbc8691c.zip
dev-util/pkgcheck: remove old
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-util/pkgcheck/Manifest2
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.6.4.ebuild58
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.6.5.ebuild58
3 files changed, 0 insertions, 118 deletions
diff --git a/dev-util/pkgcheck/Manifest b/dev-util/pkgcheck/Manifest
index e2dabf5fabf5..a6e5e3d59d51 100644
--- a/dev-util/pkgcheck/Manifest
+++ b/dev-util/pkgcheck/Manifest
@@ -1,3 +1 @@
-DIST pkgcheck-0.6.4.tar.gz 174315 BLAKE2B 147745f8dc7df3c47302b2b48a1ed0bbeec348cafbe4c7ca247c688db25b248a6d079c73e4ffc28fead4a06fc2f09aa57e8dbffffcbc765602e8d433141eaeaa SHA512 94cceccd5b184c5b810c298faa1071ec77b8ca2a618e7620dec933ea5da7beda3cb5f96a4efaf7ceb2f2059040e9ef0cbd974613011b816c10f28e59c5d32a00
-DIST pkgcheck-0.6.5.tar.gz 181861 BLAKE2B cf74c691878b3b409a7d88e0960e24dd7f1ba9d7e04eceef7f372241998721e47090aa21e46e71c5191ff2ff86392a3528c2f570b65a9b78809376a657073cb4 SHA512 e8dfd9b0e842df3bdc8044581f7bb9be6d2e671164c5966751d5df071ce3759f45f675b93ec5cfeb05362f4ba3a8a50670151068bcc6713b53e11f94d360bc18
DIST pkgcheck-0.6.6.tar.gz 186971 BLAKE2B 474bd3ddd6b0a4d4b242c631bd01bdd1351990500c1e9a3b97ae43064ea5ae4c3de57e2ea9e4574c30e52dbe1d10b35f71b2623336f42bac4af5e7e26290a208 SHA512 ef9b2126e3d295c9166f0b57902e62f8791ebe90e1dce333e787c45841a87acb0aa7e1b4ad7436d885a53aed9ce6c7d0619817e28c52b3195be49110bea8d39f
diff --git a/dev-util/pkgcheck/pkgcheck-0.6.4.ebuild b/dev-util/pkgcheck/pkgcheck-0.6.4.ebuild
deleted file mode 100644
index 3d30a06c6c24..000000000000
--- a/dev-util/pkgcheck/pkgcheck-0.6.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="pkgcore-based QA utility"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND="
- >=dev-python/snakeoil-0.8.3[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.10.3[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && esetup.py build_man
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS NEWS.rst )
- esetup.py install_docs \
- --docdir="${ED%/}/usr/share/doc/${PF}" \
- --mandir="${ED%/}/usr/share/man"
- distutils-r1_python_install_all
-}
diff --git a/dev-util/pkgcheck/pkgcheck-0.6.5.ebuild b/dev-util/pkgcheck/pkgcheck-0.6.5.ebuild
deleted file mode 100644
index 7a5d1a9d7fd6..000000000000
--- a/dev-util/pkgcheck/pkgcheck-0.6.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="pkgcore-based QA utility"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND="
- >=dev-python/snakeoil-0.8.3[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.10.4[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- use doc && esetup.py build_man
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS NEWS.rst )
- esetup.py install_docs \
- --docdir="${ED%/}/usr/share/doc/${PF}" \
- --mandir="${ED%/}/usr/share/man"
- distutils-r1_python_install_all
-}