summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-11-09 19:33:25 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-09 20:40:49 +0200
commit0e1334553eff99af56e0ac5c695876efe569b203 (patch)
treeba55e07673d0b2ad545836811da76a240d994154
parentdev-python/sqlglot: add 19.1.2 (diff)
downloadgentoo-0e1334553eff99af56e0ac5c695876efe569b203.tar.gz
gentoo-0e1334553eff99af56e0ac5c695876efe569b203.tar.bz2
gentoo-0e1334553eff99af56e0ac5c695876efe569b203.zip
dev-python/oslo-utils: add 6.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-6.3.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index c5b96cd9ec43..e2e65d1d6f1a 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1 +1,2 @@
DIST oslo.utils-6.2.1.tar.gz 104079 BLAKE2B de29980ba15488005b20190b842a499ce5964a231c1350d2e6ed43fdb4cb21909f7a31fcd21761bf01c632b82966ffa8c73ffb69e42f278e7a65d2541ae6b08a SHA512 c72be6521fa15784064c114a972943a583033be6b53b81ab955cc0601c72ef0673e1e732c492bbd798270318ec89932d7a90725f477b1cc123b173f4660d4b2a
+DIST oslo.utils-6.3.0.tar.gz 104397 BLAKE2B 1195363df16e103f49d783c644bb060719fa3b43a549e229bd1c6b8f682e36b6135fb33284f536c08460892ae441c276d9e0445f30c6a5bc6d260b9a0f4bef40 SHA512 d7d1f160865238d4dd49dec891d275455befcee1926920f22409142bbab47fe3e287ad280a72f11baa99c49beaf1d0dc52745307888b8a3edda4cb9052443336
diff --git a/dev-python/oslo-utils/oslo-utils-6.3.0.ebuild b/dev-python/oslo-utils/oslo-utils-6.3.0.ebuild
new file mode 100644
index 000000000000..0ea23aaa491c
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-6.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.utils/
+ https://github.com/openstack/oslo.utils/
+ https://pypi.org/project/oslo.utils/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ dev-python/tzdata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}"/install -name '*eventletutils*' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}