summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2024-11-29 18:52:19 -0800
committerSam James <sam@gentoo.org>2024-12-29 14:43:18 +0000
commit181986ebe563128879b90bef85c435e4544c75e2 (patch)
treea04894f11c588942c31f0b63506cf8ff4eedc85a
parentxfce-extra/xfce4-notes-plugin: Bump to 1.11.1 (diff)
downloadgentoo-181986ebe563128879b90bef85c435e4544c75e2.tar.gz
gentoo-181986ebe563128879b90bef85c435e4544c75e2.tar.bz2
gentoo-181986ebe563128879b90bef85c435e4544c75e2.zip
net-irc/atheme-services: Bump to 7.2.12-r5
Backports a0410c3 from upstream which fixes a compilation failure. Closes: https://bugs.gentoo.org/944125 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/39529 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-irc/atheme-services/atheme-services-7.2.12-r5.ebuild (renamed from net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild)7
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.2.12-libathemecore-account-fix-assertion-macro-return-type.patch37
2 files changed, 41 insertions, 3 deletions
diff --git a/net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild b/net-irc/atheme-services/atheme-services-7.2.12-r5.ebuild
index 335443e95737..fdcf9d3dbdbc 100644
--- a/net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild
+++ b/net-irc/atheme-services/atheme-services-7.2.12-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,11 +9,11 @@ DESCRIPTION="A portable and secure set of open-source and modular IRC services"
HOMEPAGE="https://github.com/atheme/atheme"
SRC_URI="https://github.com/atheme/atheme/releases/download/v${PV}/${PN}-v${PV}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${PN}-v${PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64"
IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
-S="${WORKDIR}/${PN}-v${PV}"
RDEPEND="
acct-group/atheme-services
@@ -32,7 +32,8 @@ BDEPEND="
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-7.2.10_p2-configure-logdir.patch)
+ "${FILESDIR}"/${PN}-7.2.10_p2-configure-logdir.patch
+ "${FILESDIR}"/${PN}-7.2.12-libathemecore-account-fix-assertion-macro-return-type.patch)
src_configure() {
# perl scriping module support is also broken in 7.0.0. Yay for QA failures.
diff --git a/net-irc/atheme-services/files/atheme-services-7.2.12-libathemecore-account-fix-assertion-macro-return-type.patch b/net-irc/atheme-services/files/atheme-services-7.2.12-libathemecore-account-fix-assertion-macro-return-type.patch
new file mode 100644
index 000000000000..26cc3829346c
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.2.12-libathemecore-account-fix-assertion-macro-return-type.patch
@@ -0,0 +1,37 @@
+From a0410c301293736a09b52763d25893019ede3e3a Mon Sep 17 00:00:00 2001
+From: Aaron Jones <me@aaronmdjones.net>
+Date: Mon, 25 Nov 2024 05:31:26 +0000
+Subject: [PATCH] libathemecore/account: fix assertion macro return
+ types/values
+
+---
+ libathemecore/account.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libathemecore/account.c b/libathemecore/account.c
+index 80233ade2..985cf9ff6 100644
+--- a/libathemecore/account.c
++++ b/libathemecore/account.c
+@@ -1631,7 +1631,7 @@ chanacs_t *chanacs_find_host_by_user(mychan_t *mychan, user_t *u, unsigned int l
+ mowgli_node_t *n;
+ chanacs_t *ca;
+
+- return_val_if_fail(mychan != NULL && u != NULL, 0);
++ return_val_if_fail(mychan != NULL && u != NULL, NULL);
+
+ for (n = next_matching_host_chanacs(mychan, u, mychan->chanacs.head); n != NULL; n = next_matching_host_chanacs(mychan, u, n->next))
+ {
+@@ -1779,8 +1779,8 @@ chanacs_t *chanacs_open(mychan_t *mychan, myentity_t *mt, const char *hostmask,
+ chanacs_t *ca;
+
+ /* wrt the second assert: only one of mu or hostmask can be not-NULL --nenolod */
+- return_val_if_fail(mychan != NULL, false);
+- return_val_if_fail((mt != NULL && hostmask == NULL) || (mt == NULL && hostmask != NULL), false);
++ return_val_if_fail(mychan != NULL, NULL);
++ return_val_if_fail((mt != NULL && hostmask == NULL) || (mt == NULL && hostmask != NULL), NULL);
+
+ if (mt != NULL)
+ {
+--
+2.45.2
+