summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-05 15:44:53 -0500
committerMike Gilbert <floppym@gentoo.org>2018-01-05 15:45:09 -0500
commit192d631728dac4bfd9d5e6ba7ef4011792c1861c (patch)
tree4452441353ea687330e474bdc88a81670dddc484
parentnet-misc/openvswitch: drop dependency on openrc/systemd (diff)
downloadgentoo-192d631728dac4bfd9d5e6ba7ef4011792c1861c.tar.gz
gentoo-192d631728dac4bfd9d5e6ba7ef4011792c1861c.tar.bz2
gentoo-192d631728dac4bfd9d5e6ba7ef4011792c1861c.zip
sys-apps/systemd: check for FW_LOADER_USER_HELPER_FALLBACK
FW_LOADER_USER_HELPER is not directly configurable, so it's fairly pointless to warn about it. Closes: https://bugs.gentoo.org/643606 Package-Manager: Portage-2.3.19_p3, Repoman-2.3.6_p37
-rw-r--r--sys-apps/systemd/systemd-233-r6.ebuild4
-rw-r--r--sys-apps/systemd/systemd-235-r1.ebuild4
-rw-r--r--sys-apps/systemd/systemd-236-r4.ebuild4
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild4
4 files changed, 8 insertions, 8 deletions
diff --git a/sys-apps/systemd/systemd-233-r6.ebuild b/sys-apps/systemd/systemd-233-r6.ebuild
index fded2f5f4a08..a9934d819924 100644
--- a/sys-apps/systemd/systemd-233-r6.ebuild
+++ b/sys-apps/systemd/systemd-233-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -112,7 +112,7 @@ pkg_pretend() {
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX
~CRYPTO_HMAC ~CRYPTO_SHA256 ~CRYPTO_USER_API_HASH
- ~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
+ ~!FW_LOADER_USER_HELPER_FALLBACK ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
~!SYSFS_DEPRECATED_V2"
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
diff --git a/sys-apps/systemd/systemd-235-r1.ebuild b/sys-apps/systemd/systemd-235-r1.ebuild
index a0800a27a1d6..2727ae07b8b2 100644
--- a/sys-apps/systemd/systemd-235-r1.ebuild
+++ b/sys-apps/systemd/systemd-235-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -110,7 +110,7 @@ pkg_pretend() {
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX
~CRYPTO_HMAC ~CRYPTO_SHA256 ~CRYPTO_USER_API_HASH
- ~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
+ ~!FW_LOADER_USER_HELPER_FALLBACK ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
~!SYSFS_DEPRECATED_V2"
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
diff --git a/sys-apps/systemd/systemd-236-r4.ebuild b/sys-apps/systemd/systemd-236-r4.ebuild
index 816c66a23733..be31a53ad519 100644
--- a/sys-apps/systemd/systemd-236-r4.ebuild
+++ b/sys-apps/systemd/systemd-236-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -109,7 +109,7 @@ pkg_pretend() {
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX
~CRYPTO_HMAC ~CRYPTO_SHA256 ~CRYPTO_USER_API_HASH
- ~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
+ ~!FW_LOADER_USER_HELPER_FALLBACK ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
~!SYSFS_DEPRECATED_V2"
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 7122881b52d1..7e7bcf41a449 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -108,7 +108,7 @@ pkg_pretend() {
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX
~CRYPTO_HMAC ~CRYPTO_SHA256 ~CRYPTO_USER_API_HASH
- ~!FW_LOADER_USER_HELPER ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
+ ~!FW_LOADER_USER_HELPER_FALLBACK ~!GRKERNSEC_PROC ~!IDE ~!SYSFS_DEPRECATED
~!SYSFS_DEPRECATED_V2"
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"