summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-27 08:27:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-27 09:39:28 +0200
commit237c2f8c1a4c62fd87f3aa711e2738130ebb8ac4 (patch)
tree50394576a76ed5124758f7bfe0ff3243b5071013
parentdev-python/zeroconf: Bump to 0.133.0 (diff)
downloadgentoo-237c2f8c1a4c62fd87f3aa711e2738130ebb8ac4.tar.gz
gentoo-237c2f8c1a4c62fd87f3aa711e2738130ebb8ac4.tar.bz2
gentoo-237c2f8c1a4c62fd87f3aa711e2738130ebb8ac4.zip
dev-python/pulsectl: Bump to 24.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pulsectl/Manifest1
-rw-r--r--dev-python/pulsectl/pulsectl-24.8.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pulsectl/Manifest b/dev-python/pulsectl/Manifest
index 272844960854..b5e815ff0d0b 100644
--- a/dev-python/pulsectl/Manifest
+++ b/dev-python/pulsectl/Manifest
@@ -1 +1,2 @@
DIST pulsectl-24.4.0.tar.gz 41166 BLAKE2B 3b2d41b3077f050104e7b416cb8dbba47f4282bb90ee58c855f4f5a1e1b1183b131879e6965edf8d8b5a2466ce3381e45c7a6b92f2b64fc336d311d3d7625440 SHA512 b17fd577f9c336f762925bd423fdca665afa92a88b0dae076ca016d7c5b2b3d9ef11efd27f7339031accadef00d513f972c216a23f26cfd049516f3dbcc63d01
+DIST pulsectl-24.8.0.tar.gz 41171 BLAKE2B 58a16b07fcec68f21fd573cf781f2ac09ccdf2faa3e7afa84a4f8cf9f28111e94bf41e0f8a8740434edeace78156f56ac428a87d669cbc947e331b8d555dd2e1 SHA512 4638bb41611e8d7a00f2daeec7e7783789d5d1d94841206b4052e53897e6547c21f8410c3400e1bd301e237b3a72143fb6ff3d67cbafd06bada0a1d0da007c96
diff --git a/dev-python/pulsectl/pulsectl-24.8.0.ebuild b/dev-python/pulsectl/pulsectl-24.8.0.ebuild
new file mode 100644
index 000000000000..693b086854aa
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-24.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ media-libs/libpulse
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest