summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-12-27 10:58:23 -0500
committerYixun Lan <dlan@gentoo.org>2024-12-29 00:00:11 +0000
commit3ab202e8f4c13f3993e1e843860dbcb2ea05a5cd (patch)
treee8f231732236d08115ba4ea7155370ec03a5ac2e
parentgui-libs/hyprcursor: backport fix for missing include (diff)
downloadgentoo-3ab202e8f4c13f3993e1e843860dbcb2ea05a5cd.tar.gz
gentoo-3ab202e8f4c13f3993e1e843860dbcb2ea05a5cd.tar.bz2
gentoo-3ab202e8f4c13f3993e1e843860dbcb2ea05a5cd.zip
gui-libs/hyprutils: introduce subslot
Closes: https://bugs.gentoo.org/947008 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-libs/hyprutils/hyprutils-0.3.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gui-libs/hyprutils/hyprutils-0.3.0-r1.ebuild b/gui-libs/hyprutils/hyprutils-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..c3014c430edd
--- /dev/null
+++ b/gui-libs/hyprutils/hyprutils-0.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland utilities library used across the ecosystem"
+HOMEPAGE="https://github.com/hyprwm/hyprutils"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-2)"
+
+DEPEND="
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"