summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-05 21:01:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-05 21:02:34 +0200
commit45f67db1ec35bb72db516e25879dacff65086d70 (patch)
treec81545c673de340c354a6eb1d281246f659a0135
parentsys-block/gparted: stabilize 1.6.0 for ppc, ppc64, bug #928815 (diff)
downloadgentoo-45f67db1ec35bb72db516e25879dacff65086d70.tar.gz
gentoo-45f67db1ec35bb72db516e25879dacff65086d70.tar.bz2
gentoo-45f67db1ec35bb72db516e25879dacff65086d70.zip
dev-python/tenacity: Deselect a fragile test
Closes: https://bugs.gentoo.org/935501 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tenacity/tenacity-8.4.2.ebuild4
-rw-r--r--dev-python/tenacity/tenacity-8.5.0.ebuild5
2 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/tenacity/tenacity-8.4.2.ebuild b/dev-python/tenacity/tenacity-8.4.2.ebuild
index 1c59135e8307..70c9e50d6e59 100644
--- a/dev-python/tenacity/tenacity-8.4.2.ebuild
+++ b/dev-python/tenacity/tenacity-8.4.2.ebuild
@@ -29,6 +29,10 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to timing
+ tests/test_asyncio.py::TestContextManager::test_sleeps
+ )
local EPYTEST_IGNORE=()
if ! has_version ">=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]"; then
EPYTEST_IGNORE+=(
diff --git a/dev-python/tenacity/tenacity-8.5.0.ebuild b/dev-python/tenacity/tenacity-8.5.0.ebuild
index 8c5543d52ef5..4a9349493e90 100644
--- a/dev-python/tenacity/tenacity-8.5.0.ebuild
+++ b/dev-python/tenacity/tenacity-8.5.0.ebuild
@@ -29,6 +29,11 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to timing
+ tests/test_asyncio.py::TestContextManager::test_sleeps
+ )
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}