summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-09-27 13:18:24 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2016-09-27 13:19:08 +0200
commit4ed163ded8670b559d67765f3f9ba621a3079849 (patch)
tree8ae421f0826a0e960863995eb5cfec3a90458961
parentmedia-plugins/vdr-satip: fixed gcc-6 compile; wrt bug 594170 (diff)
downloadgentoo-4ed163ded8670b559d67765f3f9ba621a3079849.tar.gz
gentoo-4ed163ded8670b559d67765f3f9ba621a3079849.tar.bz2
gentoo-4ed163ded8670b559d67765f3f9ba621a3079849.zip
app-admin/swatch: renamed to app-admin/swatchdog
To satisfy a request made by the old Swiss watch company
-rw-r--r--app-admin/swatch/Manifest1
-rw-r--r--app-admin/swatch/files/swatch-confd25
-rw-r--r--app-admin/swatch/files/swatch-init53
-rw-r--r--app-admin/swatch/files/swatch-initd52
-rw-r--r--app-admin/swatch/files/swatchrc10
-rw-r--r--app-admin/swatch/metadata.xml24
-rw-r--r--app-admin/swatch/swatch-3.2.3-r2.ebuild31
-rw-r--r--profiles/updates/3Q-20161
8 files changed, 1 insertions, 196 deletions
diff --git a/app-admin/swatch/Manifest b/app-admin/swatch/Manifest
deleted file mode 100644
index 37fb6988ba3c..000000000000
--- a/app-admin/swatch/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST swatch-3.2.3.tar.gz 31199 SHA256 e29480993e52f245f3abec079b3103d8e97244dafe754f8c2d37e7b0b3b58077 SHA512 8020fb99b7acfc322b2a80d8fd9669fc97f272c33b19a36ef1be025ffd1a463658e9b0cc5ddbac02b12a68db9e148da53734beb632677ef88337848bbd60e90f WHIRLPOOL 2fa2ff6dacec9bb527814b041951cfd5c48760cad3a94afcfe362bd13b38f0ea9b970aa7ff4882b30a5dabd79a552ea6e0ac8397e350ef88aa6569cdd7369bf3
diff --git a/app-admin/swatch/files/swatch-confd b/app-admin/swatch/files/swatch-confd
deleted file mode 100644
index 813a2a084fc7..000000000000
--- a/app-admin/swatch/files/swatch-confd
+++ /dev/null
@@ -1,25 +0,0 @@
-# /etc/conf.d/swatch: config file for /etc/init.d/swatch
-
-# Path to the swatch program.
-#SWATCH_BINARY="/usr/bin/swatch"
-
-# Swatchrc to read patterns and actions from.
-#SWATCHRC="/etc/swatchrc"
-
-# File to monitor
-#SWATCH_TAILFILE="/var/log/syslog"
-
-# Arguments to tail program
-#SWATCH_TAILARGS=""
-
-# Swatch log file
-#SWATCH_LOGFILE="/var/log/swatch.log"
-
-# Swatch error file
-#SWATCH_ERRFILE="/var/log/swatch-err.log"
-
-# Where to output the generated script to. Should not be writable by others.
-#SWATCH_SCRIPT="/var/run/swatch/swatch_script.pl"
-
-# Whether to parse the complete file once at startup. Defaults to "NO".
-PARSE_FULL="NO"
diff --git a/app-admin/swatch/files/swatch-init b/app-admin/swatch/files/swatch-init
deleted file mode 100644
index f02b066912f8..000000000000
--- a/app-admin/swatch/files/swatch-init
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/openrc-run
-# This script is based on the one created by Phil (bug #255329).
-
-depend() {
- need logger
-}
-
-SWATCH_BINARY=${SWATCH_BINARY:-/usr/bin/swatch}
-SWATCHRC=${SWATCHRC:-/etc/swatchrc}
-SWATCH_TAILFILE=${SWATCH_TAILFILE:-/var/log/syslog}
-SWATCH_LOGFILE=${SWATCH_LOGFILE:-/var/log/swatch.log}
-SWATCH_ERRFILE=${SWATCH_ERRFILE:-/var/log/swatch-err.log}
-SWATCH_SCRIPT=${SWATCH_SCRIPT:-/var/run/swatch/swatch_script.pl}
-
-gen_script() {
- local tailargs=""
- if [ "${SWATCH_TAILARGS}" ]; then
- tailargs="--tail-args=\"${SWATCH_TAILARGS}\""
- fi
- ebegin "Generating swatch script from config"
- ${SWATCH_BINARY} --dump-script="${SWATCH_SCRIPT}" \
- --use-cpan-file-tail ${tailargs} \
- --config-file "${SWATCHRC}" $1 "${SWATCH_TAILFILE}"
- eend $?
-}
-
-parse_full() {
- gen_script --examine
- ebegin "Parsing complete file once"
- /usr/bin/perl ${SWATCH_SCRIPT} 1>/dev/null
- eend $?
-}
-
-start() {
- checkpath -d -q -m 0750 -o root:root /var/run/swatch
- if [ "${PARSE_FULL}" == "YES" ]; then
- parse_full
- fi
- gen_script --tail-file
- ebegin "Starting swatch"
- start-stop-daemon --start --quiet --background \
- --make-pidfile --pidfile /var/run/swatch/swatch.pid \
- --stdout ${SWATCH_LOGFILE} --stderr ${SWATCH_ERRFILE} \
- --exec /usr/bin/perl -- ${SWATCH_SCRIPT}
- eend $?
-}
-
-stop() {
- ebegin "Stopping swatch"
- start-stop-daemon --stop --exec /usr/bin/perl \
- --pidfile /var/run/swatch/swatch.pid --quiet
- eend $?
-}
diff --git a/app-admin/swatch/files/swatch-initd b/app-admin/swatch/files/swatch-initd
deleted file mode 100644
index 76ca0ccccd55..000000000000
--- a/app-admin/swatch/files/swatch-initd
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/sbin/openrc-run
-# This script is based on the one created by Phil (bug #255329).
-
-depend() {
- need logger
-}
-
-SWATCH_BINARY=${SWATCH_BINARY:-/usr/bin/swatch}
-SWATCHRC=${SWATCHRC:-/etc/swatchrc}
-SWATCH_TAILFILE=${SWATCH_TAILFILE:-/var/log/syslog}
-SWATCH_LOGFILE=${SWATCH_LOGFILE:-/var/log/swatch.log}
-SWATCH_ERRFILE=${SWATCH_ERRFILE:-/var/log/swatch-err.log}
-SWATCH_SCRIPT=${SWATCH_SCRIPT:-/var/run/swatch/swatch_script.pl}
-
-gen_script() {
- local tailargs=""
- if [ "${SWATCH_TAILARGS}" ]; then
- tailargs="--tail-args=\"${SWATCH_TAILARGS}\""
- fi
- ebegin "Generating swatch script from config"
- ${SWATCH_BINARY} --dump-script="${SWATCH_SCRIPT}" \
- --use-cpan-file-tail ${tailargs} \
- --config-file "${SWATCHRC}" $1 "${SWATCH_TAILFILE}"
- eend $?
-}
-
-parse_full() {
- gen_script --examine
- ebegin "Parsing complete file once"
- /usr/bin/perl ${SWATCH_SCRIPT} 1>/dev/null
- eend $?
-}
-
-start() {
- if [ "${PARSE_FULL}" == "YES" ]; then
- parse_full
- fi
- gen_script --tail-file
- ebegin "Starting swatch"
- start-stop-daemon --start --quiet --background \
- --make-pidfile --pidfile /var/run/swatch/swatch.pid \
- --stdout ${SWATCH_LOGFILE} --stderr ${SWATCH_ERRFILE} \
- --exec /usr/bin/perl -- ${SWATCH_SCRIPT}
- eend $?
-}
-
-stop() {
- ebegin "Stopping swatch"
- start-stop-daemon --stop --exec /usr/bin/perl \
- --pidfile /var/run/swatch/swatch.pid --quiet
- eend $?
-}
diff --git a/app-admin/swatch/files/swatchrc b/app-admin/swatch/files/swatchrc
deleted file mode 100644
index 92e88ded1ef5..000000000000
--- a/app-admin/swatch/files/swatchrc
+++ /dev/null
@@ -1,10 +0,0 @@
-#
-# A sample configuration file for swatch.
-#
-# See "man swatch" for details.
-
-# Mails root when invalid remote login attempted.
-watchfor /(.*) (.*) (.*) (.*) (.*):( [iI]nvalid [uU]ser )(.*)( from )(.*)$/
- threshold track_by=$9,type=limit,count=3,seconds=30
- mail root,subject="Invalid user"
-
diff --git a/app-admin/swatch/metadata.xml b/app-admin/swatch/metadata.xml
deleted file mode 100644
index 65cb32fc3e19..000000000000
--- a/app-admin/swatch/metadata.xml
+++ /dev/null
@@ -1,24 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>nimiux@gentoo.org</email>
- <name>Chema Alonso</name>
- </maintainer>
- <longdescription lang="en">
- Swatch.pl started out as the "simple watchdog" for actively
- monitoring log files produced by UNIX's syslog facility.
- It has since been evolving into a utility that can monitor
- just about any type of log.
- </longdescription>
- <longdescription lang="es">
- Swatch.pl comenzó como el "simple perro guardián" para
- monitorizar activamente ficheros de registro producidos por
- la capacidad syslog de los sistemas UNIX. Desde entonces ha
- evolucionado hacia una utilidad que puede monitorizar cualquier
- tipo de registro.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">swatch</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-admin/swatch/swatch-3.2.3-r2.ebuild b/app-admin/swatch/swatch-3.2.3-r2.ebuild
deleted file mode 100644
index 6753101b099a..000000000000
--- a/app-admin/swatch/swatch-3.2.3-r2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-GENTOO_DEPEND_ON_PERL_SUBSLOT=yes
-inherit perl-app
-
-DESCRIPTION="Perl-based system log watcher"
-HOMEPAGE="https://sourceforge.net/projects/swatch/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="dev-perl/Date-Manip
- dev-perl/Date-Calc
- dev-perl/File-Tail
- dev-perl/TimeDate
- >=virtual/perl-Time-HiRes-1.12"
-
-src_install() {
- emake install
- newinitd "${FILESDIR}/${PN}-init" "${PN}"
- newconfd "${FILESDIR}/${PN}-confd" "${PN}"
- insinto /etc
- doins "${FILESDIR}/swatchrc"
-}
diff --git a/profiles/updates/3Q-2016 b/profiles/updates/3Q-2016
index 72b55e8e94f2..4f2646ec7f48 100644
--- a/profiles/updates/3Q-2016
+++ b/profiles/updates/3Q-2016
@@ -22,3 +22,4 @@ move dev-perl/data-buffer dev-perl/Data-Buffer
move dev-perl/dbix-searchbuilder dev-perl/DBIx-SearchBuilder
move dev-perl/digest-bubblebabble dev-perl/Digest-BubbleBabble
move dev-perl/digest-md2 dev-perl/Digest-MD2
+move app-admin/swatch app-admin/swatchdog