summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-12-28 20:46:12 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-12-28 20:46:26 +0100
commit57373248846ae508a9f5d41eb980de7311b8b21b (patch)
treeae1141ea752d325e73dca1a936b21506ae44a186
parentapp-editors/emacs: Force gcc for jit native compilation (diff)
downloadgentoo-57373248846ae508a9f5d41eb980de7311b8b21b.tar.gz
gentoo-57373248846ae508a9f5d41eb980de7311b8b21b.tar.bz2
gentoo-57373248846ae508a9f5d41eb980de7311b8b21b.zip
dev-ada/xmlada: drop 23.0.0-r1, 23.0.0-r3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/xmlada/Manifest1
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0-r1.ebuild86
-rw-r--r--dev-ada/xmlada/xmlada-23.0.0-r3.ebuild86
3 files changed, 0 insertions, 173 deletions
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index 8b36e9c9a64c..8c8f5b70b99e 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -1,2 +1 @@
-DIST xmlada-23.0.0.tar.gz 1053370 BLAKE2B 4edf2244818d72d6fc760f60c8145f373e5445d1d245b20b605e21faa7eeefed7835db87c1fd1239008e75211a572294e1d8e35af16c2ba2631c02d1d3b6f52f SHA512 a0fb2a34ffb5edf408fbdc1a3d68511b5545a5ec8993251ba75d71dd2a197f14e187d08f8febd71cb23bbd694889a99941911386af8468c5eb3b11128555edcb
DIST xmlada-24.0.0.tar.gz 1053363 BLAKE2B 628a1d3645c58cc3f8f5140c7cfb16adef02f6ccc72b8e9410819eaf67e0160bdcf81a8e33065ec52f54cb12309d857a3d82e532990a0fd17c249c04334ab10f SHA512 4e6773a5fdf9b6ebb5afca913d77aba9f697768f28ef9b23b9277aa4ea4ce09de4e53655dd5559e2326ff847327adb53fa6b776775aa923100a2624df415c97d
diff --git a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild b/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
deleted file mode 100644
index 67b2018ced01..000000000000
--- a/dev-ada/xmlada/xmlada-23.0.0-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ADA_COMPAT=( gnat_2021 gcc_12 )
-inherit ada multiprocessing
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -XTESTS_ACTIVATED=Only \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- emake --no-print-directory -C tests tests | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- rm -f "${D}"/usr/share/examples/xmlada/*/b__*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
- rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
- rm -f "${D}"/usr/share/examples/xmlada/*/*.o
- rm -f "${D}"/usr/share/examples/xmlada/*/*example
- rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
- rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}
diff --git a/dev-ada/xmlada/xmlada-23.0.0-r3.ebuild b/dev-ada/xmlada/xmlada-23.0.0-r3.ebuild
deleted file mode 100644
index d5f175058ac5..000000000000
--- a/dev-ada/xmlada/xmlada-23.0.0-r3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 gcc_14 )
-inherit ada multiprocessing
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
- ${ADA_REQUIRED_USE}"
-
-RDEPEND="${ADA_DEPS}"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_compile() {
- build () {
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_test() {
- GPR_PROJECT_PATH=schema:input_sources:dom:sax:unicode \
- gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=static \
- -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
- -XTESTS_ACTIVATED=Only \
- -largs ${LDFLAGS} \
- -cargs ${ADAFLAGS} || die "gprbuild failed"
- emake --no-print-directory -C tests tests | tee xmlada.testLog
- grep -q DIFF xmlada.testLog && die
-}
-
-src_install() {
- build () {
- gprinstall -XLIBRARY_TYPE=$1 -f -p -XBUILD=Production \
- -XPROCESSORS=$(makeopts_jobs) --prefix="${D}"/usr \
- --install-name=xmlada --build-var=LIBRARY_TYPE \
- --build-var=XMLADA_BUILD \
- --build-name=$1 xmlada.gpr || die "gprinstall failed"
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-
- einstalldocs
- dodoc xmlada-roadmap.txt
- rm -rf "${D}"/usr/share/gpr/manifests
- rm -f "${D}"/usr/share/examples/xmlada/*/b__*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.adb.std*
- rm -f "${D}"/usr/share/examples/xmlada/*/*.ali
- rm -f "${D}"/usr/share/examples/xmlada/*/*.bexch
- rm -f "${D}"/usr/share/examples/xmlada/*/*.o
- rm -f "${D}"/usr/share/examples/xmlada/*/*example
- rm -f "${D}"/usr/share/examples/xmlada/dom/domexample2
- rm -f "${D}"/usr/share/examples/xmlada/sax/saxexample_main
- mv "${D}"/usr/share/examples/xmlada "${D}"/usr/share/doc/"${PF}"/examples || die
-}