summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-18 22:17:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-18 22:24:07 -0400
commit5e322df0a3bb0ef31bf905c854777b7018dc869b (patch)
tree587cf276600d0bae149aacd577788a2f9f83298a
parentgames-emulation/gens: allow textrels (diff)
downloadgentoo-5e322df0a3bb0ef31bf905c854777b7018dc869b.tar.gz
gentoo-5e322df0a3bb0ef31bf905c854777b7018dc869b.tar.bz2
gentoo-5e322df0a3bb0ef31bf905c854777b7018dc869b.zip
media-gfx/ueberzugpp: improve libc++ check
Hadn't noticed we had a function for this, and had just went for a heuristic check (not that the check was important given test-flags-CXX would skip the option if unusable). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.9.6.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.9.6.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.9.6.ebuild
index 1cb4d698e37a..0d960bbdcb46 100644
--- a/media-gfx/ueberzugpp/ueberzugpp-2.9.6.ebuild
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.9.6.ebuild
@@ -54,10 +54,9 @@ BDEPEND="
"
src_configure() {
- if use X && tc-is-clang && has_version sys-libs/libcxx; then
+ if use X && [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
# X support makes use of C++20's std::jthread which is currently
- # marked experimental (at least) in <=libcxx-18 (should limit
- # version in above libcxx check whenever this becomes unnecessary)
+ # marked experimental (at least) in <=libcxx-18
append-cxxflags $(test-flags-CXX -fexperimental-library)
fi