summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-01 18:02:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-01 18:29:51 +0100
commit60a2437dece66ce290ba0ee2eb449508080bbbc5 (patch)
treeb1a4d573596d6ab0c17e3daa681db0b2786b9587
parentmedia-libs/rtaudio: Stabilize 6.0.1 x86, #945540 (diff)
downloadgentoo-60a2437dece66ce290ba0ee2eb449508080bbbc5.tar.gz
gentoo-60a2437dece66ce290ba0ee2eb449508080bbbc5.tar.bz2
gentoo-60a2437dece66ce290ba0ee2eb449508080bbbc5.zip
dev-vcs/pre-commit: bump to 4.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-4.0.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index dbcfc3b1067f..f61efa6357f2 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1 +1,2 @@
DIST pre-commit-3.8.0.gh.tar.gz 270925 BLAKE2B febb7b6bb2e43aec096e454b064b01b0973cd9d04b2d792a4ce7cef9df4f9c9c2e3bf1200f584e163c829c12ca17f57761375b297ab5c3d97dce569d5c219bdd SHA512 b6970ac00c5033938462675c20ea5e13c0439dc4f70cd627f11b22b0f87fb0a3590e9b3e9c677bfb66e4b3420f40de66ca7ccbc969847ee5fa8994532a558cd1
+DIST pre-commit-4.0.1.gh.tar.gz 286821 BLAKE2B 2d38ef4ad06744e11a75a9faddcf90f1fbb60f597d85782bf8065e90e746e62de0f7396ad09e3d03502208114ed75ed57f05ae143470b349a9b1dd6860ba72bd SHA512 93c01e4d64aa1010bdaac6e1774497fe38f757cc6b67b7546332c5fe3846583fc5ac71f70bb257e5bbe24062e060307b49abdcb539538ccedeb2cdf2243908a4
diff --git a/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild b/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild
new file mode 100644
index 000000000000..27a86ca9beb6
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-4.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL="ON"
+DISTUTILS_USE_PEP517="setuptools"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/
+ https://github.com/pre-commit/pre-commit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')
+"
+# coreutils requirement, see bug #885559
+BDEPEND="
+ sys-apps/coreutils[-multicall]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-3.1.1-tests_git_file_transport.patch" )
+
+EPYTEST_DESELECT=(
+ # All of these require a boatload of dependencies (e.g. Conda, Go, R and
+ # more) in order to run and while some of them do include
+ # "skip if not found" logic, most of them do not.
+ tests/languages/
+ tests/repository_test.py
+
+ # These three consistently fail with
+ # Calling "git rev-parse" fails with "fatal:
+ # not a git repository (or any of the parent directories): .git".
+ # including with the sandbox disabled.
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+
+ # These two fail if pre-commit is already installed (Bug #894502)
+ tests/commands/install_uninstall_test.py::test_environment_not_sourced
+ tests/commands/install_uninstall_test.py::test_installed_from_venv
+)
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )