summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 13:14:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 13:48:04 +0200
commit72fb59cee41b07bd363695e2d6432299ea50b752 (patch)
tree1c26e56394de0d2b3e56ecff5d5ffc0a5e92591b
parentnet-p2p/bitcoin-core: stabilize 26.1 for amd64 (diff)
downloadgentoo-72fb59cee41b07bd363695e2d6432299ea50b752.tar.gz
gentoo-72fb59cee41b07bd363695e2d6432299ea50b752.tar.bz2
gentoo-72fb59cee41b07bd363695e2d6432299ea50b752.zip
dev-python/sentry-sdk: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-2.6.0.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index ec6ca76b2d02..f6bca701b6e7 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,4 @@
DIST sentry-python-1.45.0.gh.tar.gz 475425 BLAKE2B 8dc46154dfc1c7c9104a706be032b5269d407dee6845da252f1c603ea4f9486d02d1d3c6bec314064b821dee31b503d07a9c17935ca1f4dd6cc4d7b9c3165094 SHA512 dad23a3f6a8e6ef5fe78e1d38a61977d8974edf306d5688537f331801d8fa0f60743d18cc3dadf6e9a9666c55a01c98b9ff8d8808ece7d8f95ee68a69b6cb9be
DIST sentry-python-2.3.1.gh.tar.gz 511775 BLAKE2B 5cc0cf6a225b8619df76492abbce76d01631148dc73aeea47d13c71435e973af7cc7904ef50e7edcde5821bce28b213b5e3ca3208887688e2d4cec1d03c7d54e SHA512 12ccd25142fd42262735babe986f9972571b4a3c48607c47c8b6887e722f53a964e259e82be56cf4c4ba6d14efe8335ebb32ed98a40a763a63a5f7b52ef6ce9e
DIST sentry-python-2.5.1.gh.tar.gz 515056 BLAKE2B fab3e6e4faa1f07879fc679d43d86fc9590ba3049f5117efe69827a5678b7292c30c9e2d04992a2d75abe54498c3e6fe0366cea210e81b92ccf302c7abcf7e3c SHA512 6467e3836af9f44be93c9a9d0b2e4cf341b7ea4b70937a9624f5d53b746f9a5d2ee5507056c3f58662e0382d88bd3a9851b2ebdf2438bd39e4d5b15096d84a3b
+DIST sentry-python-2.6.0.gh.tar.gz 519912 BLAKE2B 065aa2a633c24f163e483fe6ace9696b3bb088caae2eedaff7bbfc09213bec593f1db5a70b41f9771db602ece77d7107f51945683799de35ad59aa2c10f0a47f SHA512 f69ccc15154ea10302610329bc9d80fb9cf249a9996b99b34268468b010a24e90ca46e62b223b3331518a2ee57c6e3e028e6d6b2d1e0c9bbac4f11176403c790
diff --git a/dev-python/sentry-sdk/sentry-sdk-2.6.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-2.6.0.ebuild
new file mode 100644
index 000000000000..03fe4fa7bd6c
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-2.6.0.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+MY_P=sentry-python-${PV}
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/sentry-sdk-1.21.0-ignore-warnings.patch"
+)
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/django/test_basic.py
+ tests/integrations/socket/test_socket.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # TODO
+ tests/integrations/bottle
+ # TODO: most of them hang
+ tests/integrations/starlette
+ # TODO
+ tests/integrations/tornado
+ # requires mockupdb
+ tests/integrations/pymongo
+ # requires AWS access
+ tests/integrations/aws_lambda
+ # requires quart_auth
+ tests/integrations/quart
+ # TODO: require opentelemetry (with py3.10)
+ tests/integrations/opentelemetry
+ # broken (incompatible rq version?)
+ tests/integrations/rq
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ tests/integrations/threading/test_threading.py::test_propagates_threadpool_hub
+ # broken teardown?
+ tests/test_client.py::test_uwsgi_warnings
+ # too many dependencies installed, sigh
+ tests/test_new_scopes_compat_event.py
+ # Internet
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers
+ tests/integrations/stdlib/test_httplib.py::test_outgoing_trace_headers_head_sdk
+ # TODO
+ tests/integrations/aiohttp/test_aiohttp.py::test_basic
+ tests/integrations/django
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_orm_queries
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_query_source
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_transactions
+ tests/integrations/stdlib/test_subprocess.py::test_subprocess_basic
+ tests/integrations/threading/test_threading.py
+ tests/integrations/wsgi/test_wsgi.py
+ tests/test_basics.py::test_auto_enabling_integrations_catches_import_error
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_utils.py::test_default_release
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sample_rate_enabled
+ tests/tracing/test_sampling.py::test_records_lost_event_only_if_traces_sampler_enabled
+ tests/utils/test_contextvars.py::test_leaks
+ # pointless, fragile to packages being installed in parallel
+ tests/test_utils.py::test_installed_modules
+ # TODO
+ tests/profiler/test_continuous_profiler.py::test_continuous_profiler_auto_start_and_manual_stop
+ tests/profiler/test_continuous_profiler.py::test_continuous_profiler_manual_start_and_stop
+ tests/profiler/test_transaction_profiler.py::test_minimum_unique_samples_required
+ tests/profiler/test_transaction_profiler.py::test_profile_captured
+ tests/profiler/test_transaction_profiler.py::test_profiles_sample_rate
+ tests/profiler/test_transaction_profiler.py::test_profiles_sampler
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p aiohttp -p pytest_forked
+}