summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-10 06:32:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-10 06:32:39 +0200
commit74cb1a2a2136cf236332914f3435db1c54390f82 (patch)
tree7d3c6b57b999225b8a623445bd06c587aa45e61c
parentdev-python/botocore: Bump to 1.34.158 (diff)
downloadgentoo-74cb1a2a2136cf236332914f3435db1c54390f82.tar.gz
gentoo-74cb1a2a2136cf236332914f3435db1c54390f82.tar.bz2
gentoo-74cb1a2a2136cf236332914f3435db1c54390f82.zip
dev-python/boto3: Bump to 1.34.158
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.158.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5ad216d4a158..4946d862211f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.154.gh.tar.gz 847586 BLAKE2B 6ae763f1e112f865f8711951ac52f4ff289
DIST boto3-1.34.155.gh.tar.gz 847949 BLAKE2B 922377411d5535ff98b81f96cdb15dfd98de23bda40acabb172c889b221936083ad91403f59926fb29ca480f6d0056fb0441371dcfbd2b94d05158c34503bb8c SHA512 c8d7764c10a81fa8fb32eecdd242a36032db451bf4afe1bbc1974de422e0dc387d18e9ef78dcbdb41b19a05db4da8d66131d246b074463a33ae072a61141c362
DIST boto3-1.34.156.gh.tar.gz 848245 BLAKE2B ee690925f3e3866f0b843bebdfd48bf4bf2f63232c5207f2e3c5823f7b5142c8990b65d5cdfb14a2d14b2460c463efec6444c50733ac920b3a28188dc814adff SHA512 f42ddc6eab3cd07b80021fc3fa99c2fdeae85d70249a369d8a8d5c1e0fc7d692e78989489de8976ac66ce91327352f9df2b70574a8067bf44c1f09b4476ef0ca
DIST boto3-1.34.157.gh.tar.gz 848610 BLAKE2B a11c44d0d9685e3a1b2237b0b3d9e2927066bcb4feee6ed8198ed83b07673e53635c19328986edc2a70cad69f89db5637db09ff5768368b3494ad14aeaf4a250 SHA512 dc2e1d22d532ea398fadc653ff29642b99e2effbfb23af38288a437a0726d3191eafad481a19f6dc947d790546782e9b0b3c7926d28cf4a0f7fc0d5ac71faa6d
+DIST boto3-1.34.158.gh.tar.gz 848930 BLAKE2B 5db04b9eee08f5418a595e736f075fbe22b92adada9219e8a8cf2299c723d09e2edf88e5ebb3d09c1613a01e5d0d5c837e9545c6ee3110c430c521da10fa2bde SHA512 03f532e78a1a2b8ec01396f0b7f7bae7059165e35440eda47f4393e99d2a8ded229470cf3269a71c746b8a66dccd8626444f1e429e561df1dc1ec0f6b8653272
diff --git a/dev-python/boto3/boto3-1.34.158.ebuild b/dev-python/boto3/boto3-1.34.158.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.158.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}