summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 15:13:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 15:15:36 +0100
commit75866197e92a953b4edd47c46061dca41381867b (patch)
treedfaccfc129ec77187930af82aa1845d69728269e
parentdev-python/expects: EAPI 8, PEP517, py3.11 (diff)
downloadgentoo-75866197e92a953b4edd47c46061dca41381867b.tar.gz
gentoo-75866197e92a953b4edd47c46061dca41381867b.tar.bz2
gentoo-75866197e92a953b4edd47c46061dca41381867b.zip
dev-python/doublex-expects: EAPI 8, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/doublex-expects/Manifest1
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/doublex-expects/Manifest b/dev-python/doublex-expects/Manifest
index 0d0f75954397..773d6a3a08ff 100644
--- a/dev-python/doublex-expects/Manifest
+++ b/dev-python/doublex-expects/Manifest
@@ -1 +1,2 @@
+DIST doublex-expects-0.7.1.gh.tar.gz 6315 BLAKE2B 4af2832244578237821ba29baec54ffe1f226dfb1c92a5a03122c1a30c0e78d472ab8f75e6412a9014b97265120b5c60a8b5674cb42be58b46397a537bd534bf SHA512 2aaff2e58556ed9eb91ebb418e65058367411e011e843afb5adb08ab69705b6bdfb478d3052aae093ad1c1a1b49ba1e084e4c5510acde4874182a658330e3448
DIST doublex-expects-0.7.1.tar.gz 6315 BLAKE2B 4af2832244578237821ba29baec54ffe1f226dfb1c92a5a03122c1a30c0e78d472ab8f75e6412a9014b97265120b5c60a8b5674cb42be58b46397a537bd534bf SHA512 2aaff2e58556ed9eb91ebb418e65058367411e011e843afb5adb08ab69705b6bdfb478d3052aae093ad1c1a1b49ba1e084e4c5510acde4874182a658330e3448
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..cf9fba83fe49
--- /dev/null
+++ b/dev-python/doublex-expects/doublex-expects-0.7.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="
+ https://github.com/jaimegildesagredo/doublex-expects/
+ https://pypi.org/project/doublex-expects/
+"
+SRC_URI="
+ https://github.com/jaimegildesagredo/doublex-expects/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/doublex[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mamba[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}