summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-16 04:53:33 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-16 05:03:00 -0700
commit75b1dd0b74ffbf990524e4d03826123d75840d33 (patch)
tree3033da1041ade46b78da2635c920b568546fd429
parentdev-python/cairocffi: version bump to 1.1.0 (diff)
downloadgentoo-75b1dd0b74ffbf990524e4d03826123d75840d33.tar.gz
gentoo-75b1dd0b74ffbf990524e4d03826123d75840d33.tar.bz2
gentoo-75b1dd0b74ffbf990524e4d03826123d75840d33.zip
dev-python/xcffib: version bump to 0.9.0
Add py38 support. Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.9.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index a7d3e63b896b..cb7733fb7275 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -2,3 +2,4 @@ DIST xcffib-0.5.1.tar.gz 81274 BLAKE2B 17e19d16a5d1b5699a10bc93c80327ba2d4c38d18
DIST xcffib-0.6.0.tar.gz 84360 BLAKE2B 0947e1a20e9ad73f77e6cb000ed9fc8d70e45080edb74c5d25642c2d5ae388cc97461633e8cee1d7676557735b57b9cc1a3de459e54f96888cf7d19451d24c21 SHA512 de78b738f2a75e6569a0529d1fe2844b2cafe48623f25c20a9572ce881cb97325c3823dfe883a2e14bc93d01342f20c4ab561928312f65d0a67364fecb5c8ba5
DIST xcffib-0.7.0.tar.gz 83895 BLAKE2B b2f8f2a4fcba20bfedc4e174d61900ea20bb8968bbdff73700ceeacd6c9fa36288bfcfd67a7d4206376b3b45e6e51481604e3ea3d6aa6d9ff68eaa49df25a414 SHA512 ad655e897eb08b898e396290c0b4b64a1e228b21fc5ed1fbcb3cc73bae466fa5255d539d864f1a9fdcb1396e73f60a981e00aab82efc343c7f83c8f62a6d31c5
DIST xcffib-0.8.1.tar.gz 82979 BLAKE2B 7f253a1a6faf77830f2835cc51ae3e2138bdc826b30afded951e276056e2f6b4a1168d3440874e11d539cef84de47e02e16ec435dc7ec55b5bbb933e43f0eb8b SHA512 c7eed1f2c31d87c9ec9b7fa01e11ae3c65d2d9493fe3f4c7286901c65cb4c81382b1c41906ee537372c98b58f680530d708b81826d41eb66be45d62ab22624bf
+DIST xcffib-0.9.0.tar.gz 83063 BLAKE2B 898fbce1ff503a9ad64a4c34778e0b5ffef531cf2ad04327f1890c87adb5f91287465e39a981a3c5a628c048b8acbb38bac3b0b76a58c3bbe45ab34c9a5eacf5 SHA512 e5891f080fcf1df596c37bb64a70e0de4a41d83b4675dac3b1c128656ab1b09d865e3ab0bfe0e5cc523e89a75dc6127dfc455ab66ca543ba6eeae9ee5bdae168
diff --git a/dev-python/xcffib/xcffib-0.9.0.ebuild b/dev-python/xcffib/xcffib-0.9.0.ebuild
new file mode 100644
index 000000000000..e568cadb7fac
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ virtx nosetests -d -v
+}