summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-16 14:04:10 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-16 14:27:03 -0700
commit7ff9ce17ddb91808a8ad47246fd4eccf0410e6e2 (patch)
tree6acc1237a5728d77566951335c39a9246fff7e90
parentgnome-extra/gnome-shell-frippery: Version bump to 42.1 (diff)
downloadgentoo-7ff9ce17ddb91808a8ad47246fd4eccf0410e6e2.tar.gz
gentoo-7ff9ce17ddb91808a8ad47246fd4eccf0410e6e2.tar.bz2
gentoo-7ff9ce17ddb91808a8ad47246fd4eccf0410e6e2.zip
gnome-extra/libgsf: Version bump to 1.14.50
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.50.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index f47c6aa8594a..f8ca919e8503 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.49.tar.xz 702644 BLAKE2B 05ee17200d5170380138a7996dd37d5473eb9fe9a13cfb06b68e17470525d9640a4921d111e83963f245ecf6b669116322d9358d9a0b473c8149c56ff9c983ba SHA512 a847a3c7fe26865e110bb87cb7ed74c477fdaf41fdec1c97cd3ea85ab3ba2f618e609a38fb4087a2c9b58d8d4b430c2148c93cbbb8425af41b6c751efef3298e
+DIST libgsf-1.14.50.tar.xz 702424 BLAKE2B dc6e3fa313cc99981cf521b4613ef135ea6836554be0cc557e49d77bd3259e1bf2150af1b7a41071f4b865c28a9b6153b6ef6e89d4868e4203ce7dc7da433c71 SHA512 e4a405d01440654bfe5059536524d494e5b66859235648bcf6031a74b59967504b50750f471bbe1607c4a5ef11cac98aa2ca9ebb31151cf5a19ffa340d421adb
diff --git a/gnome-extra/libgsf/libgsf-1.14.50.ebuild b/gnome-extra/libgsf/libgsf-1.14.50.ebuild
new file mode 100644
index 000000000000..09c1888c5419
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.14.49-skip-valgrind-tests.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}