summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-22 23:18:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-22 23:31:16 +0200
commit83fb6f03552cb4774fc0f6343c1ee3b461ad17c5 (patch)
treecad8e61adeb534c40b4a66bc2abf710099cc6321
parentdev-python/websockify: Bump to 0.10.0 (diff)
downloadgentoo-83fb6f03552cb4774fc0f6343c1ee3b461ad17c5.tar.gz
gentoo-83fb6f03552cb4774fc0f6343c1ee3b461ad17c5.tar.bz2
gentoo-83fb6f03552cb4774fc0f6343c1ee3b461ad17c5.zip
dev-python/dictdiffer: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dictdiffer/Manifest1
-rw-r--r--dev-python/dictdiffer/dictdiffer-0.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/dictdiffer/Manifest b/dev-python/dictdiffer/Manifest
index 1b275b52ba2f..50b50f11bdd1 100644
--- a/dev-python/dictdiffer/Manifest
+++ b/dev-python/dictdiffer/Manifest
@@ -1 +1,2 @@
DIST dictdiffer-0.8.1.tar.gz 28555 BLAKE2B 0a6d330134c368e11e07b23d7fe592e72b64b02ede99eb2d52c2d7452b4d2505e7e3afa75ba76c30cbbd663d9cc4c073d8f236200fdfa2866c8beadd097d63b7 SHA512 e221bb0e25a35380519bf775a63fc0d692112dab15a46c8878ef2c9a6780932c8550a4486c4eab7803619a79c2f794a590a5c9ae0fbbccac04b5b11feaf38bbb
+DIST dictdiffer-0.9.0.tar.gz 31513 BLAKE2B 7f1a980b71978b49c6e41eb4b806aef8aa12e858889622d6b55741e7793e2e812a91ce6089156a080d198a9f9c8e9369e55b6e712fd5476864b2876094ea0d4f SHA512 7985b4d69d3cb08b7cf0fc8f878ac594b72c1f1e3482157c204027fff90afd9b19041e85fced12a47d5624e0b8cc1b2d6643a88295a6d212aeead76c09c24f86
diff --git a/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild b/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
new file mode 100644
index 000000000000..7cee88a5c46d
--- /dev/null
+++ b/dev-python/dictdiffer/dictdiffer-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Dictdiffer is a library that helps you to diff and patch dictionaries"
+HOMEPAGE="
+ https://github.com/inveniosoftware/dictdiffer/
+ https://pypi.org/project/dictdiffer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# Requires self to be already installed
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # remove dep on pytest-runner
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ # remove dep on pytest-pep8 and pytest-cov
+ sed -i -e '/addopts/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}