summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 11:38:31 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 11:42:35 +0100
commit863ac3f2e15170a9ad31340afb42549facdcdd8b (patch)
tree150e68cdeaad67c22931d6a0bd5af5240e810c6a
parentdev-python/graphviz: Remove redundant versions (diff)
downloadgentoo-863ac3f2e15170a9ad31340afb42549facdcdd8b.tar.gz
gentoo-863ac3f2e15170a9ad31340afb42549facdcdd8b.tar.bz2
gentoo-863ac3f2e15170a9ad31340afb42549facdcdd8b.zip
dev-python/greenlet: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/greenlet/Manifest2
-rw-r--r--dev-python/greenlet/greenlet-0.4.12.ebuild47
-rw-r--r--dev-python/greenlet/greenlet-0.4.13.ebuild47
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/greenlet/Manifest b/dev-python/greenlet/Manifest
index 7e61c768bb41..fd0c82a266e3 100644
--- a/dev-python/greenlet/Manifest
+++ b/dev-python/greenlet/Manifest
@@ -1,3 +1 @@
-DIST greenlet-0.4.12.tar.gz 57319 BLAKE2B 8260e495bb67e1a2b5b593d3513c3e2157a7b68b71fa3cb2a77de3b4ccc21b5d56bab26b6f0caf00cb669f051d22d7d6ad2700059a3d23b9ad7591f3d6608f43 SHA512 f3bf0f82b6e3bc687fc9b89469339cfb05e64518d1e49bc96066e8d47b8559f1c1aa53692cd25d839437a2f1b81df6fd9a4509a1b4063ec4ce1d97b73842e9f6
-DIST greenlet-0.4.13.tar.gz 58382 BLAKE2B a4afd9621ccd6444738c9b536af7ad5ceef5d3c8c4193ce637b4a8580c7070805419a917bef131f397286fae13f6e6f23409f5eedb814a41fcfee98356c0951a SHA512 625aaa8875b408442139191e1a63eca71c668675229907335f5caee623487aba5305c1d53b51e1764ad982b8edd07d04f984e08a75318a0a5672805667917a61
DIST greenlet-0.4.15.tar.gz 59694 BLAKE2B 8409e356e7724e1651606507d0d082e77f7f21b8884f304f5db55ce6ba6e56446525e3adc96743566b03bcdb9bdea7c47fd144554a7f60825cb191e19d6e177b SHA512 a3b7856aadc988fe153f5cf62552dd6219358f35ee2ca136e5eb5c9871cb7545986753af299e6b3e95877e9aa564559e95c548785f78e680766630b047a1ec89
diff --git a/dev-python/greenlet/greenlet-0.4.12.ebuild b/dev-python/greenlet/greenlet-0.4.12.ebuild
deleted file mode 100644
index dc2af69268c3..000000000000
--- a/dev-python/greenlet/greenlet-0.4.12.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Note: greenlet is built-in in pypy
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Lightweight in-process concurrent programming"
-HOMEPAGE="https://pypi.org/project/greenlet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="-alpha amd64 arm arm64 -hppa -ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/greenlet/greenlet-0.4.13.ebuild b/dev-python/greenlet/greenlet-0.4.13.ebuild
deleted file mode 100644
index 88fdbdcd21de..000000000000
--- a/dev-python/greenlet/greenlet-0.4.13.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Note: greenlet is built-in in pypy
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Lightweight in-process concurrent programming"
-HOMEPAGE="https://pypi.org/project/greenlet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="-alpha ~amd64 ~arm ~arm64 -hppa -ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}